How to solve this problem when installing node-red on a raspberry pi 3 2015


Node.js is no longer current. I believe there is a parameter that will tell it to install v14 or v16 instead.

in this case what to do, my friend

I also get a certification

Run the script again with --node14 or --node16 added to the end

1 Like

bash <(curl -sL -I https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered --node16)

No. At the very end of the thing you originally entered (not inside brackets)

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered) --node16

Good friend

I put the same scrip and it yields this my friend

Run this to update installed packages first
sudo apt update && sudo apt full-upgrade
Then run the script again. If still no joy then which version of raspbian are you running?

That is not a version of rasbian

What does running cat /etc/os-release in a terminal show?

I can't read that on my phone, please copy/paste text, not screen image.

Did you do the update as suggested?

ok, bullseye is fine.

So I would suggest you fix the certificate error.

try the following 3 steps...

1

sudo apt-get remove curl
sudo apt update
sudo apt upgrade
sudo reboot

2

sudo apt-get install curl
sudo update-ca-certificates --fresh

3

then try the install script once more.

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered) --node16

It is difficult to understand how the situation has arisen with bullseye. @JoanHc is this a fresh install of raspbian bullseye or did you upgrade from a previous version somehow?

I did it, but it still gives the same error.

did you do the 3 steps i outlined?