RequestError: Invalid object name

Hi. New to node-red.
It's been working great to monitor MSS tables that are updated on a schedule. But working with this specific Database is giving me issues. The error is "RequestError: Invalid object name 'WASP.dbo.WASP_config_WTC_hist'."
This works fine in MSS, not sure why node-red doesn't like this specific DB. At first I thought it was because I'm using a different server than I had been recently. But I tried some different DBs and do not get the error. Any ideas?


That mssql node is pretty much abandoned (and had several bugs & unresolved issues).

The best node for mssql is currently node-red-contrib-mssql-plus

Dang ok. Yea my entire team is using this and it looks like I'll have to delete mssql to install the mssql plus. So I'll have to get some buyoffs before getting rid of it and have them update their flows. Any other reasons people can think of why there would be an issue accessing this particular DB?

Thanks for the direction Steve. I got the buy off from my team and they're converting over. Sounds like we already use it in our prod environment, but not dev. They tested in prod and it worked great. Thanks again!

Hi again,

Well the original issue is resolved. However, now when the flow fires I receive a connection locked message on the other flows. For a little background, I have multiple flows that run on a schedule, so they fire around the same time hitting the same server. After updating using mssql plus, these errors started to occur. Am I missing something in the node that should be enabled/disabled? Or can they not all run at the same time?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.