Rfxcom node-red-contrib-rfxcom remote discovery

Hi,
I been using nodered for several months now on a Pi and I have a RFXcon RFXtrx433 transceiver hooked up to the same Pi. I can get everything working with my NEXA light switches and SciOregon sensors towards nte rfxtrx433 but I could never get any of the xxx_in nodes from the node-red-contrib-rfxcom to register a remote button push and send something out on a debug node. It feels like a really basic question but I have tried pretty much everything I can think of.
I get the green icon on the xxx-in nodes and no red triangles so all the nodes seem to have found the rfxcom transceiver I can't seem to get any indication of a remote button push.
Is there anything else I should be doing???

It works if you use the "rfx light in" node

You may need to use the RFX's own software first to configure the device. Some of the protocols overlap and interfere with each other so not every combination works.

I'm currently using:

  • LightwaveRF - remote plugs, remote controls
  • HomeEasy EU - PIR, remote plugs, mag door sensors, wireless wall switches
  • Nexa - remote plugs
  • Oregon Scientific - sensor
  • 1ByOne Doorbell

Hi,

Node author here - as Julian says, you need to enable reception of the device-specific protocols in the RFXtrx firmware itself, using the rfxmngr.exe program supplied by RFXCOM. There are two types of NEXA switches: one uses switches to set the device address, while the other uses a 'learning' mode. For the first type you need to enable the ARC protocol, for the second the AC protocol. (The protocol name forms the first part of the topic when sending or receiving messages)

1 Like

Exactly,
If you buy a NEXA remote as per today, many times bundled with switches, most likely they are AC types like this one

But you can still purchase the more expensive "excecutive" type with display & clock. This model uses the ARC type protocol

Personally I would not use the old ARC protocol anymore. Activating the ARC protocol in the RFXtrx will "kill" or at least reduce the sensitivity of some other protocols substantially. ARC and HomeEasy does play very well together. I think I remember once having a Rubicson temp/hum sensor that simply was blocked when ARC was activated. I thought ARC, AC, X10 and Oregon are the default activated protocols. Check the userguide here (page 20) http://www.rfxcom.com/WebRoot/StoreNL2/Shops/78165469/MediaGallery/Downloads/RFXtrx_User_Guide.pdf

Thanks all. I give it a try although its still a puzzle to me,specifically the remote not generating any headsup in nodered. The nexa stuff I have definitely uses ARC as I use ARC addressing in nodered nodes to get to specific plugs, i.e address ARC/A/01 in inject nodes to turn on/off the light in the room. ARC protocol plus the scientific oregon options are definitely on in the rfxtrx433 as reported by the rfxmngr. Was there something else I need to turn on to enable 'rfx lights in' node to work as intended???
Controlling the nexa switches is not the problem.
I am trying to get capture when the remote key press is done.

I am also trying to help a friend with this as he has a similar problem as he wants to capture the addresses use by his remote(not nexa but of a PT2262 chipset type).

You may find that some devices can be detected on >1 protocol. For example, I have a couple that can be picked up using either HomeEasy_EU or AC. As has been mentioned, getting rid of unused protocols can sometimes make a big different. The manual for the RFX device makes it clear which protocols interfere with each other.

My nexa switches certainly have no issues though they are not as good as LightwaveRF ones (though generally cheaper, I've brought most of my Lightwave devices when they were on offer).

Cheap PT2262 devices are different again. If the RFX is not recognising them, I think that there is a capture mode in the RFX software that you may need to use in order to capture the right signal.

Hi, Could you share what you have have turned on and off on your rtftrx422 transceiver? I have only turned on ARC and oregon scienfic on my transceiver via the rfxmngr.
The rfxtrx433 is connected to the Pi and rtfmgr only works in windows so it is troublesome to have to move the USB connection to and from the Pi every time I want to make a change, so I rather keep that to a minimum necessity.

Lets put my friend's remote PT2262 aside for the moment, so not to confused the issues. I will only add that he was able to eventually capture one of the 4 bottons on his remote(showed up on nodered but one ly one button). He could see something was happening on the rfxmngr for the other buttons but it was not appearing in nodered.

So back to (more basic) question on why nodered is not getting any headsup on any of the button push on my nexa remote. Maybe solving this would help me with my friend's problem.

In rfxmngr, you need to click 'save settings' after enabling a protocol using 'set mode', or the new settings will be lost if you unplug the RFXtrx. But it sounds like this isn't your problem.

I only run the manager app when I update the firmware which happens only once every few years since it all works for me.

But off the top of my head, here are the ones that I actually use, anything else is generally turned off:

  • LightwaveRF
  • HomeEasy_EU
  • AC
  • Byron_SX
  • Oregon

As a result of the above, I note that my auto-device log has also collected data from these additional protocols:

  • SELECT_PLUS
  • RM174RF
  • KANGTAI
  • TEMP10

Clearly these devices are in use by my neighbours but picked up by the RFXtrx433e over quite a wide distance. Maybe 20-50m or so, maybe a little more.

Another thought - have you set your rfx-lights-in node to listen for commands sent to any address?

1 Like

Looking into rfxcom.js code, you find that signals received from ARC remotes and sensors are supported.

Most likely you have a conflict between selected protocols in the RFXtrx433. In the sample below you can see how signals from my ARC remote is received and recognized (House:Unit = M:5). In Node-RED those events does also appear

But if you happen to have FineOffset/Viking checked it will block incoming ARC signals (FineOffset/Viking is for instance used by Telldus Temperature/Humidity sensors)

@striderheng - did you get it working eventually?

@maxwellhadley, sorry for the slow reply. I got distracted by something in RL and also some new Zigbee toys(raspee2 and a aqara mini switch).
I finally got around to this again. Yes, I finally got it to work. It seems like X10 and ARC options selected is not liked. Thanks again to all for the help in trying to get this working.
Another observation, the nodered nodes seems to have problem with getting a connected green light if the rfxcommanager is running(via TCP/IP option in my case).

I think that is a problem of the way serial ports work. Whichever gets it first will probably lock it. Certainly the mgr app will since it is a Windows desktop app.