Running on windows server 2012 r2

#1

Hi everyone, so as the title suggest, i'm running node-red on windows server. The server reboots it self every night at some fixed time, and when it "comes back" does not start the session, but it starts all the services except the node-red, so my question is how can i make the node-red start without having to initiate the session?

Greatings.

Andrés

0 Likes

#2

I use this program and procedure, from @dceejay, to run NR on my server. I runs flawlessly!

1 Like

#3

sorry for the silly question, does this means that i have to reinstall node-red?

0 Likes

#4

No. Just download, install NSSM, and follow the procedure in my previous reply. It is very easy.

Thanks,
Mike

1 Like

#5

thanks a lot, i'll try this.

Andrés

1 Like

#6

As you can see from the thread there, there are other ways as well. PM2 is OK. You can actually do it without any additional tools as well, just using Windows Scheduler.

0 Likes

#7

i already try the windows scheduler and didn't work, now i've tried what @arneym suggested on my test server and work flawlessly, honestly i don't know why

0 Likes

#8

Getting the quotes and paths right can be a challenge. I'm not using the scheduler at the moment as I run it manually (using W10 for my dev machine). Also, I use npm's package.json to define a "start" script with all of the parameters included so that I can do npm start, this should be adaptable for the Scheduler.

Here are some settings - this for a schedule task that is run manually. Note the non-standard location of the start folder.

2 Likes

#9

That is a great option too! I just wasn't smart enough to figure the scheduler out. I found the NSSM solution by searching "Running Node-RED as a service".

2 Likes