Salesforce (node-red-contrib-salesforce) Error:Fetch failed:Bad Request

Hi, I'm running into what is almost certainly a configuration issue on my side, but I'm not sure how to resolve it.

I've searched through the forums and found what appears to be this related issue, but I'm not still not sure if it applies or what to do with the suggested answer.

I've read through the documentation and attempted to read through the source code for node-red-contrib-salesforce but alas, I am not able to discern what is expected for the connection field values.

My setup:

  • I'm running Node-RED 3.1.0 Beta 2 on FlowForge
  • I installed node-red-contrib-salesforce v0.7.3 because the latest version requires NodeJS 18 which FlowForge does not yet support
  • The salesforce instance I'm attempting to connect to is my customer's instance in which they have created a Connected App for me based on OAuth verification

Screenshot of my current setup:

I'm sure it's something basic I'm overlooking, but here are some related notes:

  • Callback URL - Without understanding the source code better, I'm not sure if it just handles the full OAuth flow, but this is the URL I gave my customer when they set up the Connected App.
  • Environment - I selected Sandbox (Custom) so I could supply the Instance URL, but I have also tried selecting just Sandbox.
  • I confirmed the API version of v58.0 with my customer.
  • The consumer key and secret were given to me by my customer from the Connected App settings.
  • I have confirmed my username and password through other means.

With this connection config, I have attempted a very basic "SELECT Count() FROM Contacts" sort of SOQL statement which results in Error:Fetch failed:Bad Request as shown in the screenshot.

Any guidance here is greatly appreciated!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.