Sending Data to S7-1200 with S7 out Node [solved]

I would like to send some integer values to a S7-1200, reading from it works perfect but can't write.
This is my test flow to write:

[{"id":"b1743b10.6060c8","type":"s7 out","z":"b46347df.05287","endpoint":"4be02903.4c3c18","variable":"TxTimestamp","name":"Kühlsystem","x":502.95001220703125,"y":1471.933349609375,"wires":[]},{"id":"95dbda8f.07cb68","type":"inject","z":"b46347df.05287","name":"","topic":"","payload":"1","payloadType":"num","repeat":"","crontab":"","once":false,"onceDelay":0.1,"x":295.95001220703125,"y":1405,"wires":[["b1743b10.6060c8"]]},{"id":"4be02903.4c3c18","type":"s7 endpoint","z":"","transport":"iso-on-tcp","address":"","port":"102","rack":"0","slot":"1","localtsaphi":"01","localtsaplo":"00","remotetsaphi":"01","remotetsaplo":"00","connmode":"rack-slot","adapterauto":true,"adapterport":"","busaddr":"2","adapteraddr":"0","cycletime":"500","timeout":"1500","verbose":"on","name":"Kühlsystem","vartable":[{"addr":"DB26,INT52.0","name":"RunningPresses"},{"addr":"DB26,WORD54.0","name":"WaterFlow"},{"addr":"DB26,DWORD56.0","name":"TxTimestamp"}]}]

Inside the S7, it's the same DB where I do reading successful data from. For writing on it, the var's are defined as follows:

52.0   SInt
54.0   Int
56.0   UDInt

Is my test injection wrong? Watching the DB, no changes are done after injection:


Thanks for help, Frank

The Problem seems to be the connection to the S7. The debug log shows: "Keine Antwort, Neustart der Kommunikation" - No answer - restart communication. With exactly the same paramteres in the endpoint , I can read from the CPU. Are there any more debug infos to figure out the problem? The CPU has no protection mechanism set.

Thanks, Frank

Solved, have used for writing to PLC the "S7comm:write" node.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.