Serial Port RS485 question

I wanted to update my Raspberry Pi to the newest Buster + Node RED, but I have a problem to activate the "NibePi Master" ( ) in Node RED using a RS485 hat:

--> /dev/ttyAMA0 is not reachable

I think for my friend @Steve-Mcl or @UnborN is easy to help me.

I activated the serial port and then I read I have to deactivate the bluetooth service (RPi3B)

echo "dtoverlay=disable-bt" | sudo tee -a /boot/config.txt
sudo systemctl disable hciuart
sudo reboot

or "...bt3". Not sure !

I just have to know how to activate the RS485 Hat on Buster so that NibePi can find it at all.
On desktop config there are many options "I2C", "GPIO Remote", ... don´t know whats right to activate.

thats my:

Please help, even if it is only indirectly related to Node Red.

Hi Becker,

  1. Is this the same Raspberry Pi you had working before ?
  2. I thought there was an Image from NibePi that pre-installed everything needed.
    Did you start a clean install with a 2nd SD card for testing ?

There not much information on the RS-485 Hat from the link you sent us.
Its just from an online shop and no useful information regarding installation in the Datasheet on that page.

I have no experience in these Hats since i use a cheap ebay USB to RS485 for my modbus tests.
but i found an article from a similar RS485 Hat that i hope you may find useful.

sudo raspi-config
goto '5 Interfacing Options'
goto 'P6 Serial'
'Would you like a login shell to be accessible over serial?' --> NO
'Would you like the serial port hardware to be enabled?' --> YES
Finish raspi-config
reboot the Raspberry Pi

Now you can access the UART via /dev/serial0


1 Like
  1. yes
  2. yes

So I can look everything in the pre-installed Image (stretch).
I just put the RS485 hat on, and it works immediately @ /dev/ttyAMA0

Did you do as @UnborN suggested on your new installation? Does it work?

I can't go back until this evening..
I´m confused: on the pre-installed image it is ttyAMA0 and now on Buster it is ttyS0.

I´ll try.
The developer wrote:

Now I remembered that The serialport might be /dev/ttyS0

1 Like

I tried:
ttyS0 & serial0

always the same:

I found this about tty:

TtyAMA0 becomes ttyS0
But only when using a Raspberry Pi 3, since the Bluetooth interface is addressed with ttyAMA0. The
name of the UART interface is now ttyS0. If you continue to use a previous model, you can continue to
use ttyAMA0 for the UART interface.

-> I disabled bluetooth, so I think AMA0 is correct

so it looks on the other SD-card

is SPI enabled in raspi-config? SPI might be used for data transfer between PI and board.

See this documentation for example this board

Can you show us a close up picture of the HAT - we might be able to spot something from the writings on the BOARD and CHIPS that lead to documentation.

Lastly, you might want to list your current /boot/config.txt and your working /boot/config.txt - to compare & see what is enabled / disabled
(you can do this with sudo nano /boot/config.txt)

this is from the working - I think enable uart1 is missing



all from the working SD-card

Did you actually do what @UnborN said?

I asked this very question some time back

the line enable_uart=1 is missing from the boot/config.txt of the new SD card ?
so that must be the problem .. add it, reboot and try again either of the following

it works with serial0

enable_uart=1 was already in config.

I tried and changed so much, I will make a new clean SD-card and write a manual for me (and others).

but it still says: "TTY=unkown"


New fresh start.

What I did:
sudo nano /boot/config.txt
save & exit

sudo systemctl disable hciuart

sudo raspi-config
--> 'Interfacing Options'
'P6 Serial'
'Would you like a login shell to be accessible over serial?' --> NO
'Would you like the serial port hardware to be enabled?' --> YES
Finish raspi-config
reboot the Raspberry Pi

sudo nano /boot/config.txt
enable_uart=1 should be added

ls -l /dev --> looking if serial0 -> ttyAMA0


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.