[Solved] Attempt to clone node module gives errors

Can anyone help me identify where I'm doing wrong, after creating the node it shows message error Type already registered in the management palette.
sc1

I will really appreciated any help to resolve this issue.

Kind regards,
joe

Well as it says. You already have a node called that installed somewhere else in the path. Either in another directory or in a file you may have renamed.

Can you suggest what can I try? I tried to rename the files but did not resolve it. Also I did try to rename the function names within the files as well but another error occurred.

You need to find where you have installed it previously. Delete it, and restart Node-RED.

1 Like

It isn't about the file names or function names. It is the type name you pass to the registerType call.

1 Like

Thanks everyone for the response...it is a great help for me. I will go over the codes later today and see if I can fix it.

I tried to dissect the code on the js file. I found out what causes the error ("Typed already registered"). Below are the two line of codes are required but causes error.
const Denque = require('denque');
var net = require('net');

Can anyone tell how to over come this issue?

jstextFile.txt (13.4 KB)

I got it working, there was a line that I missed out.

Thanks for the help everyone,
Joe