Squeezebox "socket hang up"

I was trying to add my squeezeboxes to NodeRED, and some commands like pause, status etc do work already. I would like to have a dedicated webstream played after pushing a button but i do get a "socket hang up" and i have no clue why:

according to http://tutoriels.domotique-store.fr/content/54/95/fr/api-logitech-squeezebox-server-_-player-http.html the command should be ok.
I do have a plain html/css dropdown from history which works fine and uses the same playlist play command:

<div data-type="select" data-device="SB_Wohnzimmer" data-items='[" ","http://wdr-1live-live.icecast.wdr.de/wdr/1live/live/mp3/128/stream.mp3","http://wdr-wdr2-ruhrgebiet.icecast.wdr.de/wdr/wdr2/ruhrgebiet/mp3/128/stream.mp3","Kinderlieder"]' data-alias='[" ","1Live","WDR2","Kinderlieder"]' data-set="playlist play" class="cell w2x" ></div>

Does anyone have an idea for that?

It is always helpful to let people know what the full name of the node you are using is. It would seem that you are using node-red-contrib-squeezebox. When ever I have an issue with a node, I go to the Flowstab on this site and look up the node to check the Node Info section
Screen Shot 2020-12-22 at 7.03.06 AM

If you notice, this node hasn't been updated in 5 years. Next I follow the link to the GitHub page and look at the issues and how responsive the author is to them.

In this case it would seem that this has been abandoned by the author and seeing the age of the node, I'd be suprised if anyone has much experience with it.

You could try contacting the author directly via GitHub or you could delve into the node's code and see if you can fixit yourself.

Well, do you agree that just because something isn´t updated for a while doesn´t mean it´s not working at all? I fully agree this is not perfect, but it still doesn´t explain the issue :slight_smile: There are two plugins available and even the more recent version updated shows the same result so i assume it´s more a layer8 issue in my end.
I would appreciate if someone tells me either why my syntax is wrong or how else to make the squeezeboxes play my URL.

Ok - It WAS Layer 8 :slight_smile: I have to pass a JSON instead of a String. Layout should look like this:


just in case someone else is looking for this as well :slight_smile:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.