Tasmota node not working after Tasmota 8.30 firmware update?

I already wrote:

After a full backup, rename of the node_modules folder and
npm install
without the tasmota node, I get

added 450 packages from 410 contributors and audited 450 packages in 209.309s

Right after installing the tasmota node the same error like before:

17 May 09:45:59 - [info] Installiertes Modul: node-red-contrib-tasmota
17 May 09:45:59 - [info] Hinzugefügte Node-Typen:
17 May 09:45:59 - [info]  - node-red-contrib-tasmota:Tasmota Switch : SyntaxError: Invalid or unexpected token (line:3)
17 May 09:45:59 - [info]  - node-red-contrib-tasmota:Tasmota Sensor : SyntaxError: Invalid or unexpected token (line:3)
17 May 09:45:59 - [info]  - node-red-contrib-tasmota:Tasmota Light : SyntaxError: Invalid or unexpected token (line:3)

So I renamed the node_modules folder again (with tasmota node installed) and run npm install again:

added 493 packages from 437 contributors and audited 493 packages in 181.152s

In the startlog I can see:

17 May 09:52:35 - [info] Node-RED Version: v1.0.6
17 May 09:52:35 - [info] Node.js  Version: v12.16.2
17 May 09:52:35 - [info] Linux 5.4.35-v7+ arm LE
17 May 09:52:36 - [info] Paletten-Nodes werden geladen
17 May 09:52:46 - [info] Dashboard version 2.22.1 started at /ui
17 May 09:52:47 - [warn] ------------------------------------------------------
17 May 09:52:47 - [warn] [node-red-contrib-tasmota/Tasmota switch] SyntaxError: Invalid or unexpected token
17 May 09:52:47 - [warn] [node-red-contrib-tasmota/Tasmota sensor] SyntaxError: Invalid or unexpected token
17 May 09:52:47 - [warn] [node-red-contrib-tasmota/Tasmota light] SyntaxError: Invalid or unexpected token

But since zigbee2mqtt gets the same error when installing or running:

17 May 09:54:28 - [info] Modul wird installiert: node-red-contrib-zigbee2mqtt, Version: 0.4.1
17 May 09:54:51 - [info] Installiertes Modul: node-red-contrib-zigbee2mqtt
17 May 09:54:51 - [info] Hinzugefügte Node-Typen:
17 May 09:54:51 - [info]  - node-red-contrib-zigbee2mqtt:zigbee2mqtt-in : SyntaxError: Invalid or unexpected token (line:3)
17 May 09:54:51 - [info]  - node-red-contrib-zigbee2mqtt:zigbee2mqtt-get : SyntaxError: Invalid or unexpected token (line:2)
17 May 09:54:51 - [info]  - node-red-contrib-zigbee2mqtt:zigbee2mqtt-out : SyntaxError: Invalid or unexpected token (line:2)
17 May 09:54:51 - [info]  - node-red-contrib-zigbee2mqtt:zigbee2mqtt-bridge : SyntaxError: Invalid or unexpected token (line:2)
17 May 09:54:51 - [info]  - node-red-contrib-zigbee2mqtt:zigbee2mqtt-server : SyntaxError: Invalid or unexpected token (line:2)

...I will dive into the mqtt node, which both seems to use. Stay tuned or give an advice :wink:

I don't think you said whether you did anything else at the same time as updating the devices (which it seems is not a factor since they don't even need to be connected). Something must have changed.

Sorry, dumb question #2 from me:

So you can access the device's http page and it is configured and all that part of things is good - yes?

the device the thing with tasmota installed.

It is nothing to do with the devices, they don't even need to be connected to get the error.

As I said: Dumb question.

Sorry. Brain really not working as expected just now.
Looking for a trade-in, but not really seeing any which are better than the one I have. :frowning:

yes, I can connect to the tasmota plugs without any problem. I did not change anything.

I have just deinstalled Node-RED and in the process of installing it again!

Well something must have changed, unless you have not rebooted or restarted flows for some time, so whatever the change was it did not take effect till then.
You didn't upgrade or re-install any nodes or anything?

Edit - if the system actually works even though you see that error, are you sure the error was not there before?

I didn't upgrade or reinstall somethon when the error occured :wink:

I am quite sure, because I'm currently adding features to Node-RED and do deploy or even restart the Pi regularly. But the tasmota error just started yesterday without any change from me.

BTW: node.js v.12 is ok? I read something to stick to node.js v10 (LTS)!?

Yes, 12 is ok, but you have been using that for some time so you know that.
12 is LTS too.

I deinstalled and installed Node-RED with all nodes and settings several times now and get the errors described above with tasmota AND zigbee2mqtt, as soon as I install the node node-red-contrib-enocean.

But this combination has worked for 4-5 days. I was able to check the state of my Enocean based Hoppe door handle together with all other nodes.

Is there an alternative to use my Enocean USB300 stick with Node-RED?

It might be worth submitting an issue on the node's github page, it appears to be actively maintained.

Just done that.
I have also enabled / disabled SSL, no difference.
If I deinstall the enocean node and restart Node-RED, both other nodes continue to work again.

Can I change the subject, since the new Tasmota firmware does not seem to have any impact on the error!?

You opened the thread so you can change the topic/subject. Click the pencil icon next to it.

Probably nothing to do with your problem or issue - but there has been an emergency update for Tasmota.
It is now 8.3.1

why don't you use MQTT?
i think you are german (i'm too) and if you need some help with MQTT send me a message.

I have updated all my tasmota switches to 8.3.1 now, but no difference.
Since the error occurs, just after installing the enocean node (without using the enocean or tasmota node), there seems no correlation.

I will have to go deeper in MQTT and learn how to read the state of a smart plug over a MQTT command. I have already contacted @Maximus1, because in german it's much easier for me.

Hi Stefan,
I hope you get the problem sorted.
My mains switches are SonOff S20 devices flashed with Tasmota.
They work fine with Tasmota and "talk" nicely to/from Node-RED via MQTT.
Let me know if you want me to post some of my Node-RED flows.
Regards, David.

This is my flow with the Tasmota node:


[{"id":"b1cb0a2f.b249d8","type":"ui_switch","z":"72f946c2.13e94","name":"","label":"Heizlüfter Bad","tooltip":"","group":"1b8bd334.e6a735","order":7,"width":0,"height":0,"passthru":false,"decouple":"true","topic":"switch1","style":"","onvalue":"true","onvalueType":"bool","onicon":"","oncolor":"","offvalue":"false","offvalueType":"bool","officon":"","offcolor":"","x":480,"y":200,"wires":[["2c0fb83f.f4b8e"]]},{"id":"2c0fb83f.f4b8e","type":"Tasmota Switch","z":"72f946c2.13e94","broker":"7f211795.773398","device":"tasmotaS5","name":"Steckdose Bad","outputs":2,"uidisabler":true,"fullTopic":"","cmndPrefix":"","statPrefix":"","telePrefix":"","x":200,"y":200,"wires":[["b1cb0a2f.b249d8"],[]]},{"id":"1b8bd334.e6a735","type":"ui_group","z":"","name":"OG","tab":"f7cc43c0.99d968","order":2,"disp":true,"width":"6","collapse":true},{"id":"7f211795.773398","type":"mqtt-broker","z":"","name":"Mosquitto","broker":"localhost","port":"1883","clientid":"","usetls":false,"compatmode":false,"keepalive":"60","cleansession":true,"birthTopic":"","birthQos":"0","birthPayload":"","closeTopic":"","closeQos":"0","closePayload":"","willTopic":"","willQos":"0","willPayload":""},{"id":"f7cc43c0.99d968","type":"ui_tab","z":"","name":"BSB","icon":"dashboard","order":1,"disabled":false,"hidden":false}]

Very simple!

After deploying, it reads the actual state of the switch, I can use the physical button on the plug, I can use the button in the ui from any web browser. How do I read the current state of the plug switch with MQTT and set the button according to this state?

Due to a hint from @Maximus1 I managed to use MQTT without the tasmota node:

My former problem was, that I didn't feed the plug with a empty message, so that MQTT returns the current state back to the stat/... node:

Because of the group command tasmotas, I do not need to send it to all plugs separately.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.