Tcp connection not connected

#1

I am making a simple test flow to telnet to port23

  1. Running NodeRed on Raspberriy Pi connected to my network. THe Pi IP = 10.0.0.60
  2. Running Terminal Utility( Hercules) on Laptop . IP address = 10.0.0.66. The TCP Server is set to port 6752 for this example. I monitor the Hercules Utility to see if the message was sent.

I have created a simple flow to send 'test123' on the OUPUT TCP NODe to 10.0.0.66 port 6752.
The Node RED always says "connecting" under the TCP output node. I am not seeing the received data on the Hercules Terminal .it seems that the TCP is not making connection.

[{"id":"c6f87f53.edbe4","type":"tab","label":"Flow 1","disabled":false,"info":""},{"id":"eda8f76e.d55c48","type":"inject","z":"c6f87f53.edbe4","name":"","topic":"","payload":"test123","payloadType":"str","repeat":"","crontab":"","once":true,"onceDelay":"1","x":220,"y":320,"wires":[["754ebf38.ff66a"]]},{"id":"754ebf38.ff66a","type":"function","z":"c6f87f53.edbe4","name":"msg.payload = msg.payload + '\n';","func":"msg.payload = msg.payload + '\n';\nreturn msg;","outputs":1,"noerr":0,"x":520,"y":320,"wires":[["6992159a.1bd21c"]]},{"id":"6992159a.1bd21c","type":"tcp out","z":"c6f87f53.edbe4","host":"10.0.0.66","port":"23","beserver":"client","base64":false,"end":false,"name":"","x":850,"y":320,"wires":}]

#2

You state you have created [quote=“sweetwater, post:1, topic:548”]
OUPUT TCP NODe to 10.0.0.66 port 6752.
[/quote]

But both the screen dump and the flow JSON show port 23

#3

Thank you ukmoose.
I have tried port 23, port 6752 and 24
I can not make a connection on any.
Any ideas?

#4

You don’t say what OS the laptop is running. Are you sure you’ve allowed incoming connections on the ports you’ve tried?

#5

How have you configured the TCP node… I’ve not seen or used hercules before - but does it act as a server ? - It seems to be more likely that it is client and tries to connect to other servers - in which case you need to setup the TCP out node to “Listen On” mode rather than connecting out.

#6

Hi DCCEJAY,
NodeRED will act as the 'client'
The Hercules is being used as 'server'

I am simply trying to send from NodeRED ( ip address 10.0.0.60) and 'telnet' to the Hercules ( ip address 10.0.0.66) on Port 23 ( i have tried 23, 6752).
I can not seem to make a connection at all.

#7

Hi,
I have narrowed down the problem.
From the NodeRed ( running on Raspberry Pi, IP address = 10.0.0.60), I ran a 'PING" Node to the Laptop ( IP = 10.0.0.66) and I get a ‘False’ .
Is there some setting on the Raspberry PI or Node that I need to make so the NodeRED on Pi can communicate with other devices on the network?

#8

I have done more testing:

Laptop( IP Address = 10.0.0.66)
Raspberry Pi (running Node Red. IP address = 10.0.0.60)

From layptop , we can PING to the Node Red Raspberry PI and it is OK
From Node Red , we ran a PING node back to the Laptop and it the PING come back as FALSE ( not OK)

Is there some setting on the PI that we need to make?

#9

What happens if you open a terminal window on the Pi and try pining the laptop?
If you get no response, then the laptp is blocking it and you will have to look at your laptop settings (and I have no idea what they may be since I use a Mac)

#10

Thank you! Zenofmud. I listened to your advise and did the following to trouble shoot.

  1. On the Raspberry Pi. Opened the Command prompt and did a PING to the Laptop at 10.0.0.66
    NO PING response. So that pointed me to the solution

  2. On the Laptop, we had to disable the “firewall” in windows defender. Then it works!

Thank you to you and the amazing Node Red Community in helping me out.
I hope someone that has the same basic communication issue will eventually find this thread helpful

So for all those who are getting started and want to use a PC as the Server for testing.
Some suggestions for trouble shooting:

  1. PING from the Laptop to the NodeRED device. To establish that there is communication
  2. PING from the Node RED device back to the Laptop or server to establash there is a connection
  3. The PING node is a great tool for trouble shooting.

If you have problems PINGing to the Laptop. Check your firwall on the Virus Protection software or Windows Defender.