Node-RED Raspi refuses connection when i try to connect with my PC browser

I just installed and started Node-RED on my raspberry pi for the first time and (and least to me) it doesn't look like there's any major issues with running.

pi@raspiLV:~ $ node-red-start

Start Node-RED

Once Node-RED has started, point a browser at
On Pi Node-RED works better with the Firefox or Chrome browser

Use   node-red-stop                          to stop Node-RED
Use   node-red-start                         to start Node-RED again
Use   node-red-log                           to view the recent log output
Use   sudo systemctl enable nodered.service  to autostart Node-RED at every boot
Use   sudo systemctl disable nodered.service to disable autostart on boot

To find more nodes and example flows - go to

Starting as a systemd service.
25 Dec 10:15:07 - [info]
Welcome to Node-RED
25 Dec 10:15:07 - [info] Node-RED version: v2.1.4
25 Dec 10:15:07 - [info] Node.js  version: v14.18.2
25 Dec 10:15:07 - [info] Linux 5.10.17-v7l+ arm LE
25 Dec 10:15:08 - [info] Loading palette nodes
25 Dec 10:15:09 - [info] Settings file  : /home/pi/.node-red/settings.js
25 Dec 10:15:09 - [info] Context store  : 'default' [module=memory]
25 Dec 10:15:09 - [info] User directory : /home/pi/.node-red
25 Dec 10:15:09 - [warn] Projects disabled : editorTheme.projects.enabled=false
25 Dec 10:15:09 - [info] Flows file     : /home/pi/.node-red/flows.json
25 Dec 10:15:09 - [info] Creating new flow file
25 Dec 10:15:09 - [warn]
Your flow credentials file is encrypted using a system-generated key.
If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.
You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.
25 Dec 10:15:09 - [info] Server now running at
25 Dec 10:15:09 - [info] Starting flows
25 Dec 10:15:09 - [info] Started flows

But when i try to connect to on my PC browser it just gives me "ERR_CONNECTION_REFUSED"

I have tried to safe start it because that seems to be a common solution when you can't connect, but in safe mode i get the exact same results.

Thank you in advance for anyone willing to help.

Hi @LouisV,

Welcome to the forum.

You need to use the IP address of the Pi in place of

The 127 address is always the local address of the computer you are using. So you'd use that address if you were running the browser in the same device as Node-RED.

25 Dec 10:15:09 - [info] Server now running at

This message could be made more helpful by including the server IP address instead of 127...

I know it does quote the real IP address earlier in the startup output.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.