Connecting to Node RED Raspberry Pi dashboard shows an unsecure connection on both Pi and PC

Node-RED version: v2.2.2
Node.js version: v14.19.3

After installing Node RED on my Raspberry Pi A+ using the installation command and configuring the inital options when I tried to open the dashboard it would bring up an error page saying that it can't provide a secure connection. So I thought it might just be my PC and connected the Pi to my monitor. But it also provided the unsecure connection error, is there any way to fix this?

Here is the console

pi@raspberrypi:~$ node-red
8 Jun 00:14:19 - [info]

Welcome to Node-RED

8 Jun 00:14:19 - [info] Node-RED version: v2.2.2
8 Jun 00:14:19 - [info] Node.js  version: v14.19.3
8 Jun 00:14:19 - [info] Linux 5.15.32-v7+ arm LE
8 Jun 00:14:20 - [info] Loading palette nodes
8 Jun 00:14:22 - [info] Settings file  : /home/pi/.node-red/settings.js
8 Jun 00:14:22 - [info] Context store  : 'default' [module=memory]
8 Jun 00:14:22 - [info] User directory : /home/pi/.node-red
8 Jun 00:14:22 - [warn] Projects disabled : editorTheme.projects.enabled=false
8 Jun 00:14:22 - [info] Flows file     : /home/pi/.node-red/flows.json
8 Jun 00:14:22 - [info] Creating new flow file
8 Jun 00:14:22 - [warn]

Your flow credentials file is encrypted using a system-generated key.

If the system-generated key is lost for any reason, your credentials
file will not be recoverable, you will have to delete it and re-enter
your credentials.

You should set your own key using the 'credentialSecret' option in
your settings file. Node-RED will then re-encrypt your credentials
file using your chosen key the next time you deploy a change.

8 Jun 00:14:23 - [info] Server now running at
8 Jun 00:14:23 - [info] Starting flows
8 Jun 00:14:23 - [info] Started flows

What URL did you enter? Try explicitly entering the full URL including the http part


By default, Node-RED creates an unsecured connection rather than a secured one. As Steve says, you should use http instead of https.

If you want a secured connection, you can configure it in settings.js or you might consider an external reverse proxy to manage the TLS connectivity.

Ahh! thats it! Thank you so much. But its so weird that when i downloaded node red on my pc and entered my ip it would go though.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.