Troublehshooting flow that partially stops working

I am having an issue where the Telegram receiver for my chat stops working after some period of time.

  • Node red runs on an Ubuntu 17.04 VM
  • The receiver works and the flow responds to messages sent to the chat after rebooting the VM
  • At some point later the flow stops responding to messages sent to the chat
  • The chat doesn't seem to receive the input message at all. When the flow is working properly the blue activity indicator is triggered in some of the downstream nodes at the time messages are sent to the chat. These are not seen once the issue starts occurring.
  • There are no error messages sent to syslog when the issue first occurs or when messages are sent to the chat once the issue has occurred
  • The Telegram receiver node shows it is connected when viewing the flow
  • The remainder of the flow continues to function - I receive messages generated within the node-red flow and sent by the Telegram sender node in the same chat
  • After rebooting the VM, the chat receives and actions all of the messages missed
  • I haven't changed my configuration for several months, but this issue began about one week ago

When I redeploy the flows rather than rebooting the VM I notice the following error message on redeployment:

Jul 26 07:19:00 node-red node-red[852]: 26 Jul 07:19:00 - 
[error] [chatbot-telegram-node:c5fd291b.866488] Error stopping node: 
TimeoutError: timed out after 15000ms

The node id refers to the configuration node for my bot referenced by both the Telegram sender and receiver nodes in my flow. This leads me to think something has silently failed.

Redeploying the flows again while the bot is functioning correctly doesn't give the above error so the error seems correlated to the bot malfunction.

Of course, I've posted this info as an issue on the chatbot node github. No response there - but what I'm wondering is what I can do to troubleshoot the issue. Is there some logging I can enable to hopefully find an error message that occurs when the telegram receiver node dies, assuming that is what happens? I've checked and node-red is already starting with the verbose option.

Thanks in advance!