UI not loading or slow loading

I got an issue to bring up the UI. Not sure if this got introduced when I upgraded to 1.3.4 or not.
I run nodered in docker. I never had issues with that. I don't run many flows.
All flows work.
But when I navigate to the http UI, I just see the logo and it keeps loading for minutes without showing anything. Eventually it loads - or not.
How can I debug this issue?

thanks!

Are you talking about the editor or the dashboard?

If you were not using Docker I would suggest trying running node red with the --safe command line option, so it would not start the flows. It is possible that there is a loop or something in your flows consuming lots of processor so it takes ages to load. I don't know how to do that in Docker however.

If you look at you CPU usage, is it high?

Once the UI loads is it ok or is it slow deploying, for example.

What OS/hardware are you running on? Are you running the browser on the same machine as node-red? Are you able to try running the browser on a different machine?

Thank you Colin,
I was talking about Editor, not dashboard. Sorry if that was unclear.
CPU is low.
Deployment is fast, all flows run without delay.
I have authentication enabled. I tried disabling it, no change.
The docker runs on a debian machine along some other containers. No big I/O utilization.
Browser is remote, the debian server atually has no desktop.
I'll do some digging and see if I can solve it.
thanks for your help!
Till

Which browser are you using? Hopefully not IE.

Open the browse developer console and force a page refresh and see if it says anything. Also have a look at the Network tab in the console and refresh and see if it is hanging on something.

Done that. Figured out it was a browser cache issue in loading locales. I assume some pathes have changed after upgrade.
Clearing cache solved the issue.
thanks again for your help!
-Till

1 Like