Uibuilder and manifest.json

Julian ( @TotallyInformation) has created an awesomely powerful node in uibuilder, but of course to wield such awesome capability it is taking me some time to get everything configured just right. I have already gotten so much great direct support (feel free to look through the forum), I am now down to a single item that has me scratching my head.

When I load the default index.html or any of the many variations of it that I am hacking apart, I see this in my inspection of the page in Edge or Chrome:

The line in index.html is <link rel="manifest" href="./manifest.json"> and the file is right there in the directory. Looking at the linux command line it has the same permissions as all of the other files so I am at a bit of a loss on what is causing this to be unauthorized.

On the other hand, this is a low priority issue for me since I just got the sockets working and now and learning bootstrap-vue.

Not quite sure what you are doing to cause that. Certainly it is working on my dev system but then I don't have restrictive authorisation turned on.

You understand, I take it, that the manifest has only been provided in the default template as a way to allow your web app to load faster by more aggressive caching of the resources specified in the manifest? As such is isn't really needed like it is in Dashboard (which uses a much heavier initial load with Angular v1). Its real purpose is to enable mobile OS's to have local versions of the apps resources and so to be able to run offline.

I thought that the manifest.json file was actually being deprecated in newer browsers. But it seems that things have moved on yet again and it now seems to be back on the menu.

The 401 response is more of an ExpressJS thing not a file system thing (you would likely get a crash or at least a big error in Node-RED if the file were not readable from the FS. So the implication is that it is something to do, again, with the interaction with your auth settings in Node-RED. Though this time it would be to do with the user auth rather than the admin auth. I'll need to read through the code to see what might be happening. Too tired tonight.

Feel free to spend several weeks doing other things than supporting me in my process. I just saw the error that did not particularly affect me and thought I would fix it if there was an easy fix. Since it requires code review I would say don’t bother unless someone else has the same question.