Uibuilder - Socket.IO failed to load for NS

I tried to update from a older 4.0 version of uibuilder, to the latest. the uibuilder nodes are reporting the following when node red is deployed, and unfortuately none of my html/css/js is rendering correctly anymore. This is a vue / bootstrap-vue project.

Socket.IO middleware failed to load for NS - check that uibRoot/.config/sioMiddleware.js has a valid exported fn

Hello .. i had this issue too when i first upgraded uibuilder from an older version.
I believe the reason is that in the .node-red\uibuilder\.config folder your middleware files use older code that is no longer supported in v5.

If you havent used socket middlewares in your projects ..
just rename each of the extensions of the js files to .js-template


1 Like

OK, Thanks. My node already had both sio*.js & sio*.js-template files, so I renamed the sio*.js to sio*.js-template2. That eliminated the debug error above.

Still not rendering any VueJS pages though, even the SimpleVueJS template isn't rendering.

Do you get any errors during Node red startup
Any errors in your Browser's Dev tools ?

Have you checked in your uibuilder's node configuration .. in the Library tab that you have Vue2 and bootstrap-vue installed ?

Note: if you dont have those packages you'll have to install them (from the Library tab) but dont simply type vue because that will install vue3 which is now the default
install vue@2.7.7 since the SimpleVueJS is based on the Vue2 library (i think)

1 Like

Ahh, thank you again! I didn't realize vue3 was the default. Reverting back to Vue2 solved my issue! Hopefully I'll get some sleep tonight

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.