Unable to listen on

Whenever I try starting up Node-RED in Linux it comes up with this:

What can I do to fix this? I've been through every forum that has a similar error, and nothing works or is relatable to my problem. Any help would be greatly appreciated. Thank you for your time!

Have a look with sudo netstat -ltup what program uses port 1880.
After that you can decide if the other program or nr can be set to a different port.

1 Like

That almost certainly means you already have node-red running. Perhaps you have enabled it to run on boot. You haven't said how you have installed it, but perhaps
sudo systemctl status nodered
will give a clue.

1 Like

Hi, similar problem here.
Try to start node-red but the 1880 port is in use, it seems node-red use it. Why am I not able to access the flow using the browser?

root@beaglebone1:/home# sudo netstat -ltup
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0* LISTEN 2997/nginx: master
tcp 0 0* LISTEN 3113/dnsmasq
tcp 0 0* LISTEN 2320/sshd
tcp 18 0* LISTEN 5769/node-red
tcp6 0 0 [::]:8000 [::]:* LISTEN 1/init
tcp6 0 0 [::]:http [::]:* LISTEN 2997/nginx: master
tcp6 0 0 [::]:domain [::]:* LISTEN 3113/dnsmasq
tcp6 0 0 [::]:ssh [::]:* LISTEN 2320/sshd
tcp6 0 0 [::]:3000 [::]:* LISTEN 1/init
udp 0 0* 1861/avahi-daemon:
udp 0 0* 3113/dnsmasq
udp 0 0* 3113/dnsmasq
udp 0 0 beaglebone1.homenet:ntp* 2243/ntpd
udp 0 0 localhost:ntp* 2243/ntpd
udp 0 0* 2243/ntpd
udp 0 0* 1861/avahi-daemon:
udp6 0 0 [::]:mdns [::]:* 1861/avahi-daemon:
udp6 0 0 [::]:domain [::]:* 3113/dnsmasq
udp6 0 0 fe80::caa0:30ff:feb:ntp [::]:* 2243/ntpd
udp6 0 0 localhost:ntp [::]:* 2243/ntpd
udp6 0 0 [::]:ntp [::]:* 2243/ntpd
udp6 0 0 [::]:33204 [::]:* 1861/avahi-daemon:

Are you trying to access from the node-red box or an external computer? is not externally accessable.

Have you tried using the actual LAN IP instead?

the beagle bone black is in a private network, I use the pc browser to develop the flow and try to connect the beagle bone via browser using the 192.168.x.x IP. The ssh connection on the same IP works properly.
I tried to disable the node-red start from the boot and in this case I found the init process that occupy the 1880 port.
I'm confused!

Update: after a switch off and on (the simple reboot instruction does not provide the same result) the 1880 port was free. a node-red-stop and then a node-red-start are needed in order to have a right node-red session. Now it is possible to acces at the flow using the browser.
The next step is adding the beaglebone nodes fouded here: https://flows.nodered.org/node/node-red-node-beaglebone

It seems that a permission issue occures:

root@beaglebone1:/home/debian/node_modules# npm install node-red-node-beaglebone
npm WARN checkPermissions Missing write access to /home/debian/node_modules/node-red-node-beaglebone
npm WARN enoent ENOENT: no such file or directory, open '/home/debian/package.json'
npm WARN debian No description
npm WARN debian No repository field.
npm WARN debian No README data
npm WARN debian No license field.

npm ERR! code ELOOP
npm ERR! syscall access
npm ERR! path /home/debian/node_modules/node-red-node-beaglebone
npm ERR! errno -40
npm ERR! ELOOP: too many symbolic links encountered, access '/home/debian/node_modules/node-red-node-beaglebone'

npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2020-04-10T19_42_25_250Z-debug.log

Any advice?
Thanks a lot

The default beaglebone images already come with Node-RED and the necessary nodes - those extra nodes are not necessary. See the docs here - https://nodered.org/docs/getting-started/beaglebone

Thank you for your answer dceejay. I am at the beginning (as you proably understood) and I read the docs you linked before my post. At this point: why I am not able to find the beaglebone nodes? They do not appear between the other nodes.

These are the built in gpio nodes -

Ok, I was lookin for these ones: https://flows.nodered.org/node/node-red-node-beaglebone

Yes - those are old and no longer supported - so not necessary.

Thank you dceejay for your support. I will search for a good guide and will begin the first test; if you have some documents to advise, very welcome...