Unable to listen on

I am running node red in window 10. Initially, I did setup node-red in the task scheduler on boot up event. I am facing difficulty to view node-red cmd to view my console.log. Therefore I delete task scheduler. But still unable to view console.log because of port in use. But I am able to run node-red in

Welcome to Node-RED

2 May 14:38:14 - [info] Node-RED version: v0.20.3
2 May 14:38:14 - [info] Node.js  version: v10.15.3
2 May 14:38:14 - [info] Windows_NT 10.0.17763 x64 LE
2 May 14:38:16 - [info] Loading palette nodes
2 May 14:38:18 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
2 May 14:38:18 - [info] Settings file  : \Users\rama_\.node-red\settings.js
2 May 14:38:18 - [info] Context store  : 'default' [module=memory]
2 May 14:38:18 - [info] User directory : \Users\rama_\.node-red
2 May 14:38:18 - [warn] Projects disabled : editorTheme.projects.enabled=false
2 May 14:38:18 - [info] Flows file     : \Users\rama_\.node-red\flows_DESKTOP-4JCH2MM.json
2 May 14:38:18 - [error] Unable to listen on
2 May 14:38:18 - [error] Error: port in use

netstat -in
Check for the 1880 port.

Did you reboot after removing the task from task scheduler ?

in the title did you reall mean or was that a typo and you meant

yes, i did reboot

Its typo error. Actually its

Have you tried using a web browser and seeing what that page contains?

It’s an easy way of eliminating the possibility of node-red is still running on your machine

Hi, I did try on broswer with and Both shows Node-Red Flows. But cmd still persist with the same error after many attempts.

So node-red is already running, which is why you get the error

2 May 14:38:18 - [error] Unable to listen on
2 May 14:38:18 - [error] Error: port in use

because you can't run two copies of Node-RED on the same port.

If you reboot the machine and this happens then it would appear the task scheduler (or something else you have configured such as pm2) is starting Node-RED.

Task Manager or RUN resmon.exe (https://en.wikipedia.org/wiki/Run_command). I did run resmon.exe to monitor Overview tab and Network tab.

In the Overview tab, I am to view node-red is running and able to see port 1880 is active in the Network tab.

I did end task and restart the pc then open cmd and run node-red. It's working.

Thank you to all. Do appreciate most for your support.