Unable to make homekit-bridged work

Hi everyone!

I installed node-red on docker on my Synology NAS (ds1819+). Installation was really easy and it works perfectly!

I then installed the Philips-Hue stuff and I can control my hue accessories from node-red and receive status change without any issue.

I then installed the homekit-bridge (https://www.npmjs.com/package/node-red-contrib-homekit-bridged), trying to add a lightbulb accessory (111-11-111), deployed the stuff, went in homekit on my iphone and tried to discover the new accessory by entering 111-11-111 but nothing appears!

I'm using my Apple TV as hub. All my IOS devices are up-to-date.
I tried some different libraries like https://flows.nodered.org/node/node-red-contrib-homekit or the -preconfigured one but always the same result, I see nothing in homekit.

Does anyone have the same problem?
Thanks for any help.

I’m going to take a wild guess, because I don’t know how the Synology installation works... however, I could not get homekit-bridged to work on Docker. It works perfectly on a ‘naked’ RPi (i.e. not dockerised).

I suspect it has something to do with port access; Docker containers run within their own network, so I think I’ll have to open a port to the ‘outside world’ (my network). Perhaps it’s the same issue on Synology.

I haven’t done much research on this, but searching for ‘homekit port’ threw up some potentially useful results.

This would mean that every library could use some different ports?

Because it's working perfectly for my Hue devices!

So maybe homekit-bridged is using some ports I need to specify in docker. I'm going to ask google about it ;-). Thanks for your reply.

Just found an interesting thing to test. Add --net=host to the docker run command!

docker run -d --net=host ....

Will try it after work!

edit: found it here: https://github.com/nfarina/homebridge/issues/309

That could be it; homekit needs avahi (bonjour) to work. I’m hoping to have time to test this over the weekend.

A technology that I like best is MQTT.
For HomeKit see: https://github.com/cflurin/homebridge-mqtt

why do you prefer it? It seems a bit more complex to configure...

It's an external app, so it can also be used by other platforms like esp8266. I'm the author therefore I can’t say more :grinning:

It's working by adding the --net=host! :grinning: