Unknown: modbus-read

Hi together,

I've build a node-red reading data from modbus, with the node modbus-read. And it works.

Now, a couple of weeks later, I opened the flow and saw:

The node: modbus-read is gone. Still the flow is working (Never touch a running system).

How do I get the node back.

Do I need to uninstall first, however:

or can i simply install again ?

Any help is highly appreciated, thanks in advance.

In parallel I work on a different raspi and installed node-red there, too. Could this had have an conflict ?!?!

Did it stop working you installed the second modbus contrib node? My first guess would be that the two conflict with each other.
If it is that then remove the other one. If you can't do it from Manage Palette (which may not be possible as the node names conflict), then open a command window, go into the folder where your flows file is (usually the folder is .node-red) and run
npm remove node-red-contrib-modbus-ap...
I don't know exactly what it is called as it is off the screen. Then restart node red, refresh the browser page and see if it helps.

The "original", the first one is still working. The node just disappeared: dotted lines. I'm afraid, if I change anything in the flow and hit "deploy", it crashes.

And can it really be, that if I install node-red on a second raspi - they do interfere. They not even call the same modbus device

I didn't suggest that the two pi's conflict, I was suggesting that it may be the two modbus nodes, node-red-contrib-modbus and node-red-contrib-modbus-api that conflicted, but I have just tried it and it doesn't appear to be that.

Assuming that you have a conventional pi install of node red can you restart node red in a command window using
And post the full startup output here please? That may tell us something. I presume you have already checked that restarting node-red and refreshing the browser page does not fix it.

Yes, I use a "conventional pi", nothing special, perhaps only it's a Pi2.

I take your suggestion: "Stop and Restart" but not for now. :slightly_smiling_face:

I'm simply affraid it all crashes. :skull_and_crossbones: :smiling_imp:

Right now it's working.

The moment I need to change, I'll do it first.

Right now I'm just waiting and perhaps some else has an "easy" explanation :wink:

In that case, don't stop it, just run
that will attempt to startup another instance of node-red, which will fail as the port is already in use. It should not have any effect on the running system, but there is a good chance it will show us the problem.

Of course if you have a power glitch or similar then it will restart anyway, which could happen at a time when you are not available to fix it. At least if you try things when you are there then if there is a problem you have a chance of fixing it promptly.

That's a valid point - I think about it.

Topic solved - Raspi SD crashed :imp:

The good thing, a new SD was available and I could rebuild all - except content of InfluxdB - based on back-up's.

(Someone has a "true" statement in his signature: No back-up, no mercy !)

InfluxdB back-up available, too - however wasn't the first priority to retrieve.

I guess, the disapearence of the nodes was a first sign/indication.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.