Upgrading RPi4 to 64-bit - Node-Red Bombs

This could well be nothing to do with NR but I have to start somewhere.

As some of you know, I run Node-Red 24-7 on an RPi4 32 bit - EVERYTHING up to date....

Except as I just found out - if I wanted to re-install Grafana from scratch - they no longer support 32 bit ARM for InfluxDB - SO - with my fully working Grafana + MQTT + Node-Red setup, I (made a clone first and) did the rpi-update and the change to /boot/config.txt to say to use the 64-bit Raspbian... and rebooted.

Lovely, my existing Grafana works - and Node-Red started up - "Welcome to Node-Red" - flows started - "Zigbee2mqtt-server - refreshing device".... "email sent" - all looking good and then... "Bus Error" in the Node-Red console... NR stopped - end of story.

Any ideas as to how to progress this? I've no idea how to progress "bus error" in the NR console.

1 Like

I would guess you also need a new 64 bit version of nodejs

#Could that possibly account for "bus error"?

Yes it could

Right - new clone - apt-get-update and upgrade... then sudo rpi-update - then the bit in config.txt.

Powers up as AARCH64. Done - and of course, NR is still dead. How do I update my Nodejs 14.74 to 64-bit - any idea? In ignorance I tried sudo apt full-upgrade - no changes. I tried your script - it left nodejs alone....

Uninstall it and re-install it
sudo apt remove nodejs
sudo apt install nodejs

On second thoughts I don't know if that will make a difference. In fact I don't understand what the change in config.txt actually does. Are you sure that changing it will allow grafana/influx to install?

Preparing to unpack .../nodejs_14.17.4-1nodesource1_armhf.deb ...

Detected old npm client, removing...

Looks like it re-installed the same one.

The change in config.txt definitely changes the login info from arm7 to aarch

Right I'm booting.

Linux rpi419buster 5.10.52-v8+ #1440 SMP PREEMPT Tue Jul 27 09:56:40 BST 2021 aarch64

That AARCH64 wasn’t there before the config.txt change -= even after rpi-update.

Nope – same old nodejs it seems

Oh, dear… Still no Node-Red. Good job this was a clone... oh and I've not yet tackled the 64 but Grafana - I believe that Grafana issue happened at the apt update and apt-upgrade before the rpi-update - as I did apt update and apt upgrade only a couple of days ago on my main SSD and everything was/is working perfectly at that point.

Any other ideas guys?

Is influx running?

Its the old influx - I'm not worried about that... that came later. The NR BUS ERROR appeared from the first time I upgraded to 64 bit RPI op system... :slight_smile: One thing at a time :slight_smile:

Are you sure? repos.influxdata.com still seems to have armhf packages for 1.8, or are you trying to install influxdb v2.0?

Personally I'm happy with 1.8 but people using my script obviously want the latest version.

But the Influx is not the main issue – Node-Red bombing out at the start is the big problem.



You need the aarch64 version of nodejs. You may need to install it manually as I have tried using the script for it.

Thanks Dave but I've no idea how to get to the latest binary for that.. I've always just used firstly my own script -bit more recently - yours.

Well. Now you are one step ahead of me ! Dive in !
( did you try re-running my script but with the —node14 flag added to force a re-install?)

I could try that now if I could grasp where to put that --node14 flag - I tried it at the start, in the middle - at the end - erm, no... So - where would you put that flag? (don't you hate dumb questions)..

At the end.
If you put --help at the end instead, it will print out all of the options (the script doesn't run with --help)

Yup - it's removing the old version 14.x and installing 14.17.4 but no idea if it's the 64 bit verdion (uname -m shows aarch64)... - I'm getting excited now....

Sadly - same result - "Bus Error"

I'm depressed again...

You already tried uninstalling and re-installing it, so doing that again won't help.