Version 1.2.7 does not install some nodes

Hi there,

due to a crash I had to reinstall my system. I have now installed version 1.2.7 (automatically) Now I had to find out that I can no longer install node vl53lox, for example.
On my old version 1.06 it works without any problems.
How can I reinstall the old version)
Many Thanks.

Thoralf

Better to show us the error so you can fix that. It won't be the version of node red causing the problem, though it might be the version of nodejs. Or it might be because you have not installed the build tools.

Hi there, in the attachment the log view. Thoralf

error log.txt (107 KB)

My interpretation of that is that node-red-contrib-easybotics-vl53l0x is pulling in a very old version of i2c-bus (1.2.5) which is not compatible with nodejs 12 which you have installed. Normally one would submit an issue against the node to get it updated. Unfortunately the github repo for the node has not got issues enabled, however the authors page on gihub has got a email address so I suggest you try emailing the issue.

Thanks, I'll do that

Hi there,
nevertheless I add my question. I use the following command line for the installation:
bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)
As a result, the latest version of Node Red will be installed.
What should the command be if I want to install version 1.0.6, for example. Of course you can find this version on the Github. Can you load the zip file locally on the Raspberry and install it locally, or as mentioned above, rewrite the command line above that version 1.0.6 is installed.

Many Thanks

Thoralf

To install a particular version of a module you can specify the version in the npm command line. So to install node red version 1.0.6 you can use
sudo npm install -g --unsafe-perm node-red@1.0.6
You have to use sudo and -g when installing node red as it is installed globally.
That won't fix your problem though, as I said, it is not the version of node-red that is the problem but nodejs.

Hi there,
Super thank you!!!
I'll test this out tonight.
I absolutely lack the knowledge of Nodered's structures. So I'm really grateful for your help.
I'm just comparing my two systems. Why can I install the vl53lox node on my old Raspberry (Nodered 1.0.6) and not on the other Raspberry (Nodered 1.2.7).
Of course I like the current version better and will contact the developer for the node vl53lox as agreed.
There is also a successor vl53l1x, maybe he can change something there.

Many Thanks!!!
Thoralf

Hi @pinie_pinie

On your older system you have an older version of Node.js - the underlying runtime that Node-RED uses.

Any node module that has a binary component must be built against the Node.js runtime to work. It would appear the module you are trying to use does not compile against the latest version of Node.js.

The version of Node-RED is irrelevant in all of this.

On your older system, you could run node -v to find out what version of node.js you have there.

Hi, there is a fork on github that is much more up-to-date and is using "i2c-bus": "^5.2.0" in package.json instead of "i2c-bus": "^1.2.2"...

You should be able to install direct from github like this...

cd ~/.node-red
npm install sany1231/node-red-contrib-vl53l0x

Worth a try?

Hi there,

it is difficult for a layperson to understand the whole system.
But I roughly understood your answers and will test them tonight.
Many thanks for your quick answers. I'll get back to you with my findings, maybe it will help other users too.

Thanks!
Thoralf

Hi there,
I can fully confirm your statements from this morning. The node (vl53lox) with the new link can be installed without any problems. On my old system there is version 10.18.1 (node -v), on the new V 12.20.1.
Now I have a problem with the node "node-red-contrib-nube-logic". This cannot be installed either. Probably the same cause (see log)?
Can this be reported centrally so that the node can be adapted?
In any case, I learned a lot today.

Many Thanks!
ThoralfError log.txt (16.4 KB)

there is an issue raised over 1 year ago on the github repository...

Is there anything that node provides that you really need?

Most of its nodes look easily replaceable with standard or supported contrib nodes.

Hi there,

i use the "math" function in my project. Surely there are other nodes that can be used.
If the problem has been around for so long, I have to look further.
Thanks for the hint.

Thoralf

I tried this and the other new version that was published by easybotics and neither of them is working correctly I believe. The sensor is supposed to report the measurement every so many milliseconds, as defined by the polling interval in the node. However, you only get one reading after starting the polling and nothing else happens. The reading appears to be correct, but you have to continually poll the node in order to get the reading. I don't know what logs I can pull to try and help with this but I'm more than happy to if someone wants them.

Hi,

I am not the specialist, but I can confirm that. I am therefore using your version and am satisfied.
A question:
I have now ordered the vl53l1x rangefinder. This can probably measure up to 4m.
Is there already a node for it?

Thoralf