When installing new nodes, I see this error/message

I have the nodes installed on other machines.

New machine:

2020-08-05T01:39:14.444Z Install : node-red-contrib-samsung-tv-control 1.3.12

2020-08-05T01:39:14.540Z npm install --no-audit --no-update-notifier --no-fund --save --save-prefix="~" --production node-red-contrib-samsung-tv-control@1.3.12
2020-08-05T01:40:07.461Z [err] npm WARN 
2020-08-05T01:40:07.474Z [err] deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
2020-08-05T01:40:25.050Z [err] npm
2020-08-05T01:40:25.056Z [err]  WARN deprecated har-validator@5.1.5: this library is no longer supported

I can't work out if that is a error or a warning.
Yes, it does say err which I know implies ERROR....... But to what extent is it an error?

At the end does it say it has installed, showing the version number? If so then it has installed ok. However, if it using an unsupported module then it probably does not have a long term future, if it even works now.