2.0.1 error (networking?)

I realise there was an update to this node in the 2.0.0 update. However, my http request node is not working and I'm not sure where to start.

I have a number of flows that scrape the web for prices/changes etc. They are no longer working. Even the example node red flow now no longer works.

[{"id":"60e13f.444b8ec","type":"inject","z":"8c249630.076968","name":"make request","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"","crontab":"","once":false,"onceDelay":"","topic":"","payload":"","payloadType":"date","x":270,"y":60,"wires":[["3ae79c65.53df84"]]},{"id":"3ae79c65.53df84","type":"http request","z":"8c249630.076968","name":"","method":"GET","ret":"txt","paytoqs":"ignore","url":"https://nodered.org","tls":"","persist":false,"proxy":"","authType":"","x":430,"y":60,"wires":[["42222945.5f2ba8"]]},{"id":"da9563c0.49724","type":"debug","z":"8c249630.076968","name":"","active":true,"tosidebar":false,"console":false,"tostatus":true,"complete":"payload","targetType":"msg","statusVal":"payload","statusType":"auto","x":990,"y":60,"wires":[]},{"id":"42222945.5f2ba8","type":"html","z":"8c249630.076968","name":"","property":"","outproperty":"","tag":".node-red-latest-version","ret":"html","as":"single","x":630,"y":60,"wires":[["da9563c0.49724"]]}]

Any thoughts?

Edit: the flow was taken from this documentation, and it's also broken.

try this

[{"id":"bb365f9c2f3b3a2e","type":"tab","label":"Flow 1","disabled":false,"info":""},{"id":"60e13f.444b8ec","type":"inject","z":"bb365f9c2f3b3a2e","name":"make request","props":[{"p":"payload"},{"p":"topic","vt":"str"}],"repeat":"","crontab":"","once":false,"onceDelay":"","topic":"","payloadType":"date","x":330,"y":260,"wires":[["3ae79c65.53df84"]]},{"id":"3ae79c65.53df84","type":"http request","z":"bb365f9c2f3b3a2e","name":"","method":"GET","ret":"txt","paytoqs":"ignore","url":"https://nodered.org","tls":"","persist":false,"proxy":"","authType":"","x":490,"y":260,"wires":[["42222945.5f2ba8"]]},{"id":"da9563c0.49724","type":"debug","z":"bb365f9c2f3b3a2e","name":"","active":true,"tosidebar":true,"console":false,"tostatus":true,"complete":"payload","targetType":"msg","statusVal":"payload","statusType":"auto","x":1050,"y":260,"wires":[]},{"id":"42222945.5f2ba8","type":"html","z":"bb365f9c2f3b3a2e","name":"","property":"payload","outproperty":"payload","tag":".node-red-latest-version","ret":"html","as":"single","x":690,"y":260,"wires":[["da9563c0.49724"]]}]

You had to set payload as the msg property.

2 Likes

I think you may have posted the wrong flow, as its still errors for me. Can you screenshot the change please?

try this

[{"id":"bb365f9c2f3b3a2e","type":"inject","z":"799f73e7022a279b","name":"Make request","props":[{"p":"payload"}],"repeat":"","crontab":"","once":false,"onceDelay":"","topic":"","payloadType":"str","x":210,"y":240,"wires":[["3ae79c65.53df84"]]},{"id":"3ae79c65.53df84","type":"http request","z":"799f73e7022a279b","name":"Get nodered.org","method":"GET","ret":"txt","paytoqs":"ignore","url":"https://nodered.org","tls":"","persist":false,"proxy":"","authType":"","x":380,"y":240,"wires":[["42222945.5f2ba8"]]},{"id":"da9563c0.49724","type":"debug","z":"799f73e7022a279b","name":"","active":true,"tosidebar":true,"console":false,"tostatus":true,"complete":"payload","targetType":"msg","statusVal":"payload","statusType":"auto","x":790,"y":240,"wires":[]},{"id":"42222945.5f2ba8","type":"html","z":"799f73e7022a279b","name":"","property":"payload","outproperty":"payload","tag":".node-red-latest-version","ret":"html","as":"single","x":590,"y":240,"wires":[["da9563c0.49724"]]}]

Thanks, something is wrong with my node-red install, as I just spun up a docker 2.0.1 image and it worked with your flow. Thanks for the help.

This is the error
image

Yeah I kind of figured, because I tried them on multiple device and they all work for me.

1 Like

Any suggestions as to where to start? I've tried re-installing node red (using the bash command), and same error. I can ssh and RDP into the device (armbian), I can use the web with other applications, just not node red. It gives the error below.

RequestError: connect ECONNREFUSED 127.0.0.1:44

Hi @GeorgeCastanza

we had a similar issue reported overnight, but they then tried a new container and it worked - the issue was then closed.

Clearly there is some subtle issue here, I'm just not sure what it is as yet.

1 Like

Anything I can do to help debug?

@GeorgeCastanza Can you provide some more info on your docker config, how did you upgrade node-red in the container that has the issues?

I dont run that instance of node red in docker. It's run bare metal, installed by bash pi script (without the pi modules, as I'm running on armbian).

I did spin up a node red via docker to check the error, which was where the confusion originated.

thats useful thanks, we were thinking this was a docker related issue.

any info you can share about your network setup on the device, DNS, proxies etc?

No proxies. Standard Unifi setup. There is a pi-hole running on the network. I just tried to do the http request after disabling the pi-hole, and it still failed.

I've got a few http requests, some external, some internal to my network. One internal request is scraping my wifi connected solar invertor, and that also failed after 2.0.1. So it's probably not DNS.

Thanks sounds very similar to the setup I have here, I'm just updating one of my Pi's to 2.0.1 so will see if that has the same problem

I am using node-red with docker and tonight after an automated upgrade (with watchtower) to 2.0.1 (from 1.3.5) my Postgres nodes stopped working.
Downgraded to 1.3.5 and everything is fine again.
I post it here because it might be a networking issue.

Is the request to the solar inverter using a local hostname or a IP address? Please share details of exactly how that http-request node is configured

IP address.

And that is giving the ECONNREFUSED 127.0.0.1:443 error when making a request to that IP address?

I'm just double checking this as I'm struggling to reproduce this anywhere at the moment.

Yes, that flow in original post is the flow (amongst many) that produce those errors.

Also can you run npm list agent-base in your Node-RED userDIR (probably ~/.node-red) and paste the output please