2.0 and 2.0.1 docker images aren't working on RPi4

As soon as the final 2.0 was released I pulled the new image on my Raspberry Pi 4 but the logs show only standard_init_linux.go:228: exec user process caused: exec format error and NR isn't working at all but keep restarting

Just tried this and got

pi@pi420190710:~ $ docker run -it -p 1881:1881 -v node_red_data:/data --name mynodered nodered/node-red
standard_init_linux.go:211: exec user process caused "exec format error"

as well

(I don't normally run docker - I just did this to see if was unique to OP but it's not)

Yup - we're aware and investigating. For some reason dockerhub is returning the x86_64 image rather than the arm image.

Does anyone have a previous known good tag if I was running node-red:latest previously? Just to get it up and running while it's being investigated? I've tried to back track all the way to 2.0.0 so I'm now faced with latest-10 and latest-12 not sure which one to go for.

The 1.3.5 tags are listed in the readme here: node-red-docker/README.md at v1.3.5 · node-red/node-red-docker · GitHub

I am running 2.0.1-14-minimal on RPI4 just fine.

We have rebuilt the 2.0.1 images and they should now be working.

1 Like

I can confirm that now 2.0.1 is working.
Thank you very much

1 Like