adminAuth for Login

#1

I commented "adminAuth:" in the settings.js file, but authentication remains.
And otherwise i change login and password but still login failed.
And i try to reinstall node-red but same problem
so how to access directly without login to 127.0.0.1:1880

0 Likes

#2

I have resolved!

0 Likes

#3

How? So if other people find this thread they can learn from what you did...

2 Likes

#4

for the first time, I modified the settings.js file under this path / usr / lib / node_modules / node_red: it's false
but the solution is to modify the settings.js file under the folder /root/.node_red/

0 Likes

#5

That should generally be the settings.js file under the user who is running Node-RED.
so for example of a pi. If using the user pi you generally be using the file in /home/pi/.node-red

(the settings.js file gets copied into this directory the first time you run Node-RED)

This is documented here: https://nodered.org/docs/configuration

Unless there is a specific reason to run as root it advisable not to.

1 Like