Alexa Smarthome node: Too many requests. Try again in some time

Hi Folks
Anyone experienced this error recently whilst using the Smarthome node to operate Smart devices via Alexa routines. Just started happening last week whilst I was away from home. I tested it pretty thoroughly before I left and seemed to be working reliably then.



Yes, same here. First noticed when nodered didnt trigger amazon devices via flows as previously worked flawlessly. Troubleshooting sees a mix of this error (error response: Too many requests. Try again in some time.) and not devices showing in smarthome node when looking to query

I hope someone will be able to shed some light on this issue as I've put a lot of hours into these flows and routines. I wonder if Amazon have changed anything at their end which could be causing this.

Hi guys,

have a look failed to load smarthome devices: "Cannot convert undefined or null to object" · Issue #70 · bbindreiter/node-red-contrib-alexa-remote2-applestrudel · GitHub


Thanks for the link ciachoo. I found that upgrading my alexa-remote2-applestrudel node to 5.0.11 seems to have solved the issue for now. Will monitor the situation and report back if it starts "playing up" again.

If upgrading yours alexa-remote don't help you please change user-agent settings :wink:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.