Alexa with node red

I have a simple flow of an alexa home node connected directly to a mqtt input node (sonoff basic). Both show connected. when i ask alexa to turn on sonoff2, the green light comes on OK but alexa says that its not responding and to check connections to the sonoff basic. When asking alexa to turn off, the green light goes out OK but alexa says the same not responding message. Is this normal, any ideas what i'm doing wrong?. (I have updated the sonoff basic firmware with tasmota)

Tick the auto acknowledge option in the node settings or as the info bit says..

Auto Acknoledge tells Alexa the command suceeded no matter what. If you untick this option you will need to add a Alexa Home Response node to the flow.

Hi, thanks for the tip, it worked a treat. I just ticked the auto acknowledge box.