[Announce] Dashboard 2.21.0

A quick update to Dashboard to move us up to Gridstack version 0.6.4
and fix a small bug with date inject for pre-setting the form and also you can now set the hover-over tooltip dynamically if you so wish.

As usual - don't forget to flush your local browser cache properly after restarting the server side.

2.21.0: Milestone Release


  • Let tooltip words be settable via {{msg.something}}. Issue #578.
  • Move Gridstack to v0.6.4 - thanks HiroyasuNishiyama. PR #581,580


  • Fix Form Date input to accept inject of date correctly.

2 days after you posted, still does not show up.

Due to an oversight, it only got published to npm a short time ago. Flow library should pick it up soon.

Unable to update through manage palette.Following error generated.

what's your node-red-log (when node-red start) ?
Mine is this and working good :

Welcome to Node-RED
22 Apr 09:29:17 - [info] Node-RED version: v1.0.4
22 Apr 09:29:17 - [info] Node.js  version: v10.19.0
22 Apr 09:29:17 - [info] Linux 4.19.93-v7+ arm LE
22 Apr 09:29:18 - [info] Loading palette nodes
22 Apr 09:29:27 - [info] Dashboard version 2.21.0 started at /ui
22 Apr 09:29:29 - [info] Settings file  : /home/pi/.node-red/settings.js
22 Apr 09:29:29 - [info] HTTP Static    : /home/pi/Documents/node-red-static
22 Apr 09:29:29 - [info] Context store  : 'default' [module=localfilesystem]
22 Apr 09:29:29 - [info] User directory : /home/pi/.node-red
22 Apr 09:29:29 - [warn] Projects disabled : editorTheme.projects.enabled=false

Strange: there is an "editorTheme" deactivated !? I didn't notice it before the update :thinking:

We have seen some recent npm caches being broken for some reason. - maybe try checking your npm cache and then retrying

cd ~/.node-red
npm cache verify

The npm repository seems to have been having occasional issues recently causing corruption of the npm cache. Try this and then try the update again
npm cache clean --force

In fact it would be interesting to know what @dceejay's suggestion reveals, try that first and let us know what happens.

to have a point of comparison RPI 3B 1Go RAM: for my part I successfully installed 2.21.0

$ npm cache verify
Cache verified and compressed (~/.npm/_cacache):
Content verified: 2466 (258119459 bytes)
Content garbage-collected: 701 (24182276 bytes)
Index entries: 3488
Finished in 60.544s

@SuperNinja, Here is the log

i just test on my win10 PC and :

22 Apr 20:55:30 - [info] Node-RED version: v1.0.4
22 Apr 20:55:30 - [info] Node.js  version: v12.16.1
22 Apr 20:55:30 - [info] Windows_NT 10.0.18363 x64 LE
22 Apr 20:55:30 - [info] Loading palette nodes
22 Apr 20:55:31 - [info] Dashboard version 2.21.0 started at /ui 

With node.js v12.16.1 and NR v1.1.4 => the update is ok

@dceejay, @Colin and @SuperNinja Thanks each one of you. Tried npm cache verify , but it did not work. The solution, however, suggested by Colin worked for me. :+1: for Colin.

1 Like

@SuperNinja Thanks, it ultimately worked for my windows 10 as well. Yes, for sure, there was not any problem with the update, rather it was to do something with the cache of npm package manager on my machine.

1 Like

OK, thanks for that. So the verify said there was no problem, but actually there was corrupt data there, which was fixed by clearing it out and refreshing it.

@Colin Thanks, it was as you elaborated. In my language, it's a common idiom

lataun kay bhoot bataun say nahi mantay

meaing if someone is not responding you the polite way, better take a harsh step. What @dceejay suggested was probably a safe method (polite way) for a novice like me, but finally a surgical treatment came to the rescue. :stuck_out_tongue_winking_eye:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.