[Announce] node-red-contrib-opc-da

Hi Tiago,

It's a Ubuntu 18.04, Node-red V1.0.4 running under Docker.

OPD DA node version 1.0.3.

My flow is quite simple, it is a OPC DA node which reads from an OPC DA Server and stores its value into a variable. This variable is uploadad to influxDB every 10 seconds.

Do you need the .json?

What about the Windows Version of the OPC-DA server, do you know which version is it?
Would be also great if you could post the flow here.

Its a Win XP SP3 running RSLinx Classic V2.57. But I also tried on a Win 7 running RSLinx Classis latest version.

You will find attached a sample of the flow.

flows (1).json (3.5 KB)

I got also these errors:

We have a few installations running OPC-DA and we don't have this problem. I saw your flow and seems pretty normal.
I think the only way to help you is to go a bit deeper and collect some tcpdumps (using wireshark), can you do that?

Thanks for your reply Tiago.

Yes of course. I can set up a sniffer using wireshark when the problem occurs.

Hello friends

Thank you very much for this development.

I have a problem, I need to connect the OPC-DA Node with a Siemens spectrum power OPC server that runs under windows server 2012, what is the CLSID of that server, I don't know, please help.

Scada: Spectrum power 5

OPC DA server

Operating System: Windoes server 2012

The error displayed is: "2147746132 - The given Clsid is not registered on the server"

Please do not know which Clsid to place

Check if it helps you:

What about connecting to a local OPC server which is part of a Workgroup instead of a domain? What should I type as the domain input? Or must I switch to using a domain instead of a workgroup in order to get this working? I have no idea what possible consequences this might have on other applications running on the server though.

Regarding the domain, it is actually not required if you don't have any domain set at the server side, so you can simply type "Workgroup" as domain, or maybe ".", Windows will simply ignore it if it's not required.

1 Like

Hello,

First of all, good job!

I've test with SIMATIC NET OPC DA server and it worked with your node. :grinning:

Now I am testing it for the final application with AMS OPC DA server and I have some problems.

As you can see in the image below, I am connect to local AMS OPC DA server successfully with OPC expert.

I am able to get the Clsid from it and to get the URL too.

Thing is I am not able to get any items when I use the node. :cry:

I tried the IP address of the network card and "localhost" instead of the "HFW7/AMS.OPCServer.1" OPC expert is suggesting me and nothing works..

Anyone can give me help please? @machadotiago

OPC expert can be a gateway from DA to UA but the license cost is out of this project budget.

Best regards,
HugoD

Hi Tiago.

I have set 2 RSLinx OPC servers to communicate with Node-red using opc-da node, one running on Win XP and other on Win10.

I have set DCOM permissions to enable access from NodeRed.

Windows XP works fine, but I cannot get online in NodeRed with the OPC server running on Windows 10.

Do you have any guess?

Try to enable SMBv1 (I know, it sound strange but it should do the magic on Windows 10)

Hi Tiago.

SMBv1 was disabled indeed, but I have enabled it and still no connection.

In the Win10 event viewer I can see NodeRed logging in successfully, which is good...

Nodered throws the following error: "2147746066 - Unknown error!"

This library is part of ST-One and the professional support is provided only to ST-Ones customers.
You can post an issue here in the repository, but I have to say that since we don't have support from any company to keep it public and free, this library will be, from time to time more and more dependant on ST-One Hardware and tend to drop it's functionalities from all other OSs.

Hi @machadotiago,

Firstly, the ST-one products look very good & a great addition to the market, however, your philosophy on the following point looks like you guys might be heading in a different direction?

That is (IMO) a somewhat disappointing approach to this. I would guess node-red is a selling plus point for the ST-one products so keeping your nodes up-to-date on all platforms would surely benefit both yourselves (dependable software == good reputation) and for the community that provides node-red to your company? I would guess the ST-one users are using more than the S7 and OPC nodes i.e. dashboard and the thousands of other nodes the community have released for everyone (including ST-one product owners) to use

You are 100% right, that's why I recommended posting the issue on GitHub so that maybe other developers could help solving the problem (OPC-DA node has a few contributors out of our company that can help solving issues).
About the compatibility with others OSs and HWs, I also agree but we receive dozens of e-mails every week requesting free support for something that is usually out of our standard environment and we don't have enough people (and resources) to help everyone, that's why we alert that the professional support and full compatibility is provided only for our customers, but the community still has the power to keep it strong.

2 Likes

Hi, I understand & that is perfectly reasonable. Thank you for the feedback.

Hi Tiago,

To give you a feedback, I was able to communicate with the OPC server running on Windows 10.

The OPC Server which I was using was a RS Linx Classic OEM, that apparently does not work with the OPC NA node.

I got a RS Linx Classic Gateway trial licence from Rockwell and it worked flawlessly.

Thank you again.

Hi,
I went through your documentation, I am unable to connect, it's says incorrect user or password.

Can u please refer Unable to configure "opc-da in "

Thanks.