AWS Cloud MQTT IOT connection Problem

Hello NODE-Red- Forum!

Not sure if this is a node red problem, but maybe someone has experience with it.
Its like a kind of Hybrid ..

I want to connect with Node-red via the mqtt node to the aws IoT. I use a Simatic IOT2040 which has actually a Arduino Uno in it with node-red. I have also a Temperature Sensor connected to it, which i want to stream.
But i run out of ideas and cant get it work.
What have I tried yet:
For the aws Cloud.

I followed step by step this guide:

  • registry my IOT
  • downloaded the certificate public, private, the certificate as well as the root CA.
  • create first txt file, write the rootCa in it, save it as pem file.
    • via WinSCP on my Simatic /home/root/... folder

    • activate it

    • Attached it to my Simatic

-create policy
--Action iot:* Resource ARN *
--Attach it to my certi
As well with configure a device Linux & node.js

    • with the download kit on the device

    • add permissions chmod +x

    • ./

installed this nodes:

Sending but not incoming at the cloud

In Node-Red:
First i tried it with the default mqtt broker
Server: The Endpoint Http
Enable Secure SSL/TLS configuration:

  • Certificate: on my Simatic /home/root/... folder the Certificate file ending .pem
  • Private key:on my Simatic /home/root/... folder the Certificate file ending xxxprivate.key
  • CA Certificate; on my Simatic /home/root/... folder the 'manual' with txt file created CA root file.

Notice ; No Errors --> Started "Connecting" but never is "Connected"

For testing i just typed "payload" in the topic in the Cloud as well in the nodes and ot should give me to the sensor values.

So, what am I missing?

Kindly regards!


Have you looked at the open issues for the AWS node?
Try comparing your policy against the one that the user got to work (in issue 1) (with the standard MQTT node)

I swear.. I have nothing changed... But now it works..
Sometimes programming take, sometimes programming give you something.

But Thank You for your quick answer!

I was having similar issue with the node-red standard mqtt node. I updated the Policy to make the policy (on AWS IOT end) more permissive and it worked.Then I got into the issue of connection-disconnection state which was solved by changing the QoS on the Out node to 0. it was 2.