Backup of flows - no access to webinterface after installing a node

Hi, unfortunately i have no access to node red webinterface after installing the node: node red speaker pi

this is the error message:

is there also a possibilty to backup the flows, or where is the file location of the flows?

Many Thanks

Have you tried starting in safe mode node-red --safe?
You could also remove that node via the CLI - change to the .node-red directory (cd .node-red) and use npm remove node-red-contrib-speakerpi and then see if you can start up again.

node-red --safe doesn't help, when I run the remove command following appears

after the remove, can you start node red?

no unfortunately not, the same error

Well you can remove the node in terminal by
cd .node-red' 'cd node_modules
then delete the folder for that node
rm -rf node-red-contrib-speakerpi
and then start node-red again.

i have deleted it but when i start the same error appears

is it possible to find the existing flows via cli?

Your flows are in the ~/.node-red directory.


where exactly?, this is the ls output

Why are you those folders. Start again with
cd $HOME
which should get you back to the Pi directory. Then
cd .node-red
npm remove node-red-contrib-speakerpi

You have shared the ls output of a completely different directory to the one I pointed you at.

ok sorry,
i found the right directory:
but there is another error:

it's not node red start it is node-red-start

yes also with node-red-start i got the error.

in the meantime i found the flows. I think I will start from scratch and flash a new raspbian.

Many Thanks for all your help.