Bug in dashboard/slider node?

Hi, I just wonder if this is an expected functionality or not:

In the slider node, when configured "continuously while sliding", the node send both the min and max values without a problem when at the "outer ends" even if you slide fast. However, when configured "only on release" it is very difficult to "hit" the end points so that a message is sent even if the display shows the end values correctly. In the flow editor, you can also see that the values where not correctly set

In "continuously while sliding" mode, the actual value is not shown in the dashboard gui but it does in "only on release" mode

In both modes, the min value is not shown along the node in the flow editor if the min value is configured to 0 (zero)

Dashboard version 2.16.0
NR version 0.20.7

I'm sorry - I don't understand the question(s).

What is not understood? I'm asking if the slider behavior is expected or if there is a bug (or several)
Should I provide a sample flow to demonstrate?

Try this flow

[{"id":"30c700e4.5d09b","type":"ui_slider","z":"d01d2553.fd9838","name":"","label":"only on release","tooltip":"","group":"94cd9b77.f34d68","order":1,"width":0,"height":0,"passthru":true,"outs":"end","topic":"","min":0,"max":"255","step":1,"x":170,"y":1400,"wires":[["76bb9916.0ba488"]]},{"id":"a82376b6.0a19a8","type":"ui_slider","z":"d01d2553.fd9838","name":"","label":"continuously while sliding","tooltip":"","group":"94cd9b77.f34d68","order":1,"width":0,"height":0,"passthru":true,"outs":"all","topic":"","min":0,"max":"255","step":1,"x":200,"y":1460,"wires":[["c9e34355.96e5a"]]},{"id":"76bb9916.0ba488","type":"debug","z":"d01d2553.fd9838","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"false","x":420,"y":1400,"wires":[]},{"id":"c9e34355.96e5a","type":"debug","z":"d01d2553.fd9838","name":"","active":true,"tosidebar":true,"console":false,"tostatus":false,"complete":"false","x":420,"y":1460,"wires":[]},{"id":"94cd9b77.f34d68","type":"ui_group","z":"","name":"Sliders","tab":"8f57f520.e87078","disp":true,"width":"6","collapse":false},{"id":"8f57f520.e87078","type":"ui_tab","z":"","name":"Some stuff","icon":"dashboard","order":3,"disabled":false,"hidden":false}]

@krambriw are you using Safari?

I just tried your flow (in Safari) and while it it difficult to get the end value I was able to do it. But it seems like you have to move your cursor to the point you want the slider to go and click, not click/hold the slider and move it.

I then tried it in FireFox and in Chrome and it worked just as you would expect.

Hi Paul,
I started using <chrome, now tried with Safari as well as with RPi browser directly, same behavior
Sometimes you are "lucky" with just drag & release, but most of the time an additional click is required

It works as expected for other values in between min/max so something is not working correctly

BTW: you also noted that the value of zero (0) is not shown in the flow editor?

Ahh yes I see it is missing

1 Like

There are two things going on

  1. the status not displaying 0 is already fixed in latest beta
  2. the not sending when you slide past end of widget before release is it not catching the leave event as if it was a mouseup event. So while it is working as it should it could be better. fix on way.

released as part of 2.16.1


Fantastic!!! What a quick update!

It was maybe more a "cosmetic" issue,,,but everything that makes NR even better in the minor details

Kind regards, Walter

1 Like

Good timing just as I was pushing out 2.16.1 :slight_smile: