Did I hit a bug? Slider node

#1

Configure slider node like in this flow .

[{"id":"ce5cda8b.5f9118","type":"ui_slider","z":"b02a69cb.a920e8","name":"","label":"slider","tooltip":"","group":"ea5f3f04.58db4","order":0,"width":0,"height":0,"passthru":true,"outs":"end","topic":"","min":"50","max":"100","step":1,"x":330,"y":320,"wires":[[]]},{"id":"ea5f3f04.58db4","type":"ui_group","z":"","name":"Default","tab":"843d2ff8.6cf31","disp":true,"width":"6","collapse":false},{"id":"843d2ff8.6cf31","type":"ui_tab","z":"","name":"Home","icon":"dashboard","disabled":false,"hidden":false}]

Slider doesn't work and value is always 100.

System info:

11 Apr 14:30:01 - [info] Node-RED version: v0.20.5
11 Apr 14:30:01 - [info] Node.js  version: v10.14.0
11 Apr 14:30:01 - [info] Windows_NT 10.0.17134 x64 LE
11 Apr 14:30:02 - [info] Loading palette nodes
11 Apr 14:30:04 - [warn] rpi-gpio : Raspberry Pi specific node set inactive
11 Apr 14:30:04 - [info] Dashboard version 2.15.0-beta started at /ui
0 Likes

#2

Working fine for me...
you do have it set to send on release only - so it will only send one value when you release.

0 Likes

#3

Tried, still same. Very strange. I'll try harder :slight_smile:
2.15.0-beta is of course beta still but....

0 Likes

#4

hmm oh yeah didn't spot that... yes its a bug

0 Likes

#5

in html it swaps min and max

<md-slider ng-if="me.item.outs==='end'" md-discrete="" flex="100" min="100" max="50" step="1" ng-model="me.item.value" aria-label="50-100" ng-change="me.valueChanged(10)"

0 Likes

#6

pushed new beta for you...

0 Likes

#7

Ouch how fast :smiley:

0 Likes