Can I use IPV6 address in SNMP node's Host field?

I have an SNMP node set up and working with V3 to an IPV4 device. I am now trying to get the same result but to the IPV6 address for the device. I get the error "Error: getaddrinfo ENOTFOUND FD15"

So do I need to format the IPV6 address a certain way or does this node not support IPV6?

Some more details:::
I have the device's IPV6 address which is fd15:4305:b3dc:7fb:20f:9cff:fe01:1598 (IPV4 is NodeRed is running on a linux based machine which has the following setting from ifconfig " inet netmask broadcast
inet6 fd15:4305:b3dc:7fb:fdd2:9c45:756f:dea8 prefixlen 64 scopeid 0x0
inet6 fe80::5fc:28c5:1217:f3a2 prefixlen 64 scopeid 0x20
ether 00:0c:29:3b:15:4f txqueuelen 1000 (Ethernet)
RX packets 49077536 bytes 6428688761 (5.9 GiB)
RX errors 0 dropped 5279420 overruns 0 frame 0"

so it appears to me both can use IPV6. PING -6 from NodeRed server to device works.

I've tried both the IPV6 address "fd15:4305:b3dc:7fb:20f:9cff:fe01:1598" (no "s around it) as well as a version with "[ ]" around it like this: [fd15:4305:b3dc:7fb:20f:9cff:fe01:1598] in the Host field. Neither worked.

Looks like it is splitting on colon (as if it a port number that follows an ipv4/hostname)

Which package is it?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.