Node-red IPv6 Listening

I have installed node-red at raspberry-pi
My internet-provider use ds-lite which only use IPv6 to access from outside.
How can i access node-red with ipv6.
Normally ipv4 "" works
Example IPv6-adress is 1a0:2a02:9018:2221:5120:96d8:fb11:5815.
ipv6 "[21a0:2a02:9018:2221:5120:96d8:fb11:5815]:1880" does not work for access to node-red.
ipv6 "[21a0:2a02:9018:2221:5120:96d8:fb11:5815]:80" does work for access to web server.
It seems, that node-red does not listen to IPv6, only IPv4.
What and where do i have to adjust for solving the problem?
greetings Uwe

Are you trying to access your pi from outside your local network?

From your internal network, get on the Pi and find it's IP address. From terminal enter ifconfig and you should be able to find your I address, something like 192.168.1.?? or 10.0.0.??.

From a browser yes that address plus :1880 For example my pi has an IP address of so to access it from my mac, I open Safari and enter to get into the backend.

It looks like you are correct, Node-RED does not seem to create an IPv6 Listener.

Thankfully, it seems as though someone else already hit this issue and Dave answered it:

The answer is to change uiHost in settings.js - that file contains information on what to change.

Thanks for your help.
Changing settings.js to uiHost: "::" works.

1 Like