Can not get USB serial work with Node-Red

Dear All, I am a newbie and it is my first time using Node-Red.

My Node-Red is running on Raspberry Pi 4. For learning purpose I am trying to read ESP32 device connected to RPi via USB. I am able to display the output in terminal using "screen /dev/ttyUSB0 115200". But the problem is, Node-Red can not recognize the serial input, showing:
"serial port /dev/ttyUSB0 error: Error: Error: No such file or directory, cannot open /dev/ttyUSB0".
Basically, it shows "not connected". Is there anything I am missing?
When I run "sudo ls /dev/ttyU*" command, I can see "/dev/ttyUSB0" listed.



In terminal run


and copy/paste here the resulting output.

Hi Collin, I did. Strange... The output is: -bash: node-red-stop: command not found.
node-red commands do not work.

That suggests you did not install using the recommended technique

I have installed it using IOTstack.

We have not heard of that (here in the core project) - you may be better off talking direct with the owner of that project.

Or starting again using the script in the link I posted.

My problem is solved. For more information please refer to the link: