Cannot access node red in browser on some PCs

Hello, I have a problem with the display of the dashboard.
I am working with the IoT2040 in an application that collects data and sends it to the node-red dashboard. At first when I tried to enter the dashboard with the address (It is the Iot2040 IP address), it did not allow me since the iot2040 gateway was not configured, in this case it had to be, then I configured it and I was able to enter with a PC, the problem is that I cannot enter from another device on the same network, it has already been verified that the gateway, IP and mask were on the same network, but it is not possible to connect on another device other than the first PC. There will be some restriction in the ethernet network that I am not taking into account, I hope to have some idea of ​​what is happening.


Is node-red running on the iot2040 or some other computer?

The dashboard should be at the same IP address as the node-red editor

No, node red is not running on the other computers. Only in the IoT.
Yes, the node red editor is at the same address as the dashboard.

What device are you able to access the dashboard from, and what URL do you use to access it?
What devices are you able to access the node-red editor from, and what URL do you use to access that?

All devices are PCs.
To access the node-red editor I use
And to access the dashboard I use

On which devices do each of those work, and on which devices do they not work?

With the device that works is the

With the device that does not work is the IP:
and the other is IP:
both have the same mask and gateway.

The strange thing is that from any device on the network I can ping the IoT2040

You said at the start that you cannot access the dashboard. Do you mean that from 180.25 and 180.24 you can access the editor but not the dashboard, but from 180.26 you can access both the editor and dashboard?

What symptom do you see when you try?
Are you using the same browser and version on all PCs?

From 180.24 to 180.25 I can't access anything.

Node-Red runs on the IoT2040, the PCs are only for viewing the dashboard.

Correct, they all have the same browser, I tried with another and still nothing

When I try to access both the dashboard and the editor, it stays loading the page and shows nothing.

OK, so it is nothing to do with the dashboard in particular. I will move this to the General category.

Open the browser developer console in the browser, how to do that depends on the browser, I am sure your favourite search engine will help if you don't know how. Refresh the node red page and see what it says in the console

1 Like

Hi @Disaile12 What kind of configuration did you mean?

As test, you could install node-RED in another device (another PC in the same network) and try access to Node-RED.

Hi, @Disaile12

You wrote:

No, this is not strange.
ICMP (ping) works on the IP (network) layer (OSI layer 3), while TCP and UDP works on the Transport layer (OSI layer 4). ICMP doesn't work with ports, while TCP/UDP does.

Did you already check the Firewall settings in the PC's with addresses and Compare it with the setting of Check that port 1880 is open.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.