Cannot install node-red-contrib-ui-clock after dashboard update

I wonder if anyone can offer some guidance please?

Whilst attempting to upgrade Dashboard from 2.30 to 3.1.2, I discovered node-red-contrib-ui-clock was causing issues. After deleting this, the upgrade was fine.

However, I am unable to reinstall this node and it would seem there are dependency issues. I have tried to find a way to contact the author of this fine node to seek his opinion but have been unable to discover any method to do so.

Any ideas, please?

All advice gratefully received!

What do you see if you go into your .node-red folder and run
npm install node-red-contrib-ui-clock?

I have just tried it and you are right, it will not install with the latest dashboard.

$ npm install node-red-contrib-ui-clock
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: tigger@1.0.0
npm ERR! Found: node-red-dashboard@3.1.2
npm ERR! node_modules/node-red-dashboard
npm ERR!   node-red-dashboard@"~3.1.1" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer node-red-dashboard@"^2.23.2" from node-red-contrib-ui-clock@1.0.1
npm ERR! node_modules/node-red-contrib-ui-clock
npm ERR!   node-red-contrib-ui-clock@"*" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

The correct way to report this is via the node's github page, which is linked to from the node-red flows site. Issues · patrickknabe/node-red-contrib-ui-clock · GitHub

Many thanks, Colin.

Not just me then!

I have placed a note on GitHub and hopefully the problem might be addressed in due course.

It does install if you add --legacy-peer-deps to the command, which tells it to consider that a warning rather than a failure. It may well work ok, so give it a try.

Restart node red after running the install.

...and we're back!

Thank you very much for that workaround, Colin.

It does appear to work after a brief trial but flags up a few issues during installation which hopefully the Author might be able to resolve in due course. It certainly isn't going to get any better as the projects progress through future updates.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.