Cannot move or adjust widgets in Dashboard

A working dashboard deployment no longer permits me to move widgets on the layout. I have been editing layouts with no issues, moving and re-sizing widgets at will. I added a gauge to the dashboard and deployed and the dashboard appeared stuck.
The widgets have the lock icon locked, with no oblique arrow bot-right. Clicking the lock unlocks, but the widget just sizes to a large size on its own - still no oblique arrow bot-right in the widget. Click lock again, and the widget stays large and the lock icon shows locked.
I can size the page by clicking on the page width control ( up/dn) and widen the page - the widgets do odd things - grow bigger on their own, some even grow larger than the defined page area.

I have shut down node red - restarted, deleted all flows, deployed, imported the last functional version of my flow - the deployed dashboard shows correct in the browser, but I can still not move/size any widgets in the dashboard editor.
.json version - 20.2.0
node-red version 3.0.2
Dashboard Version 3.5.0

This install is a few months old, was always working.
I have no hidden or disabled flows or nodes.
There was not a windows 10 update, etc, prior to this issue.
Tried on chrome and firefox

Any help greatly appreciated - many searches have not!

What is the maximum width of your groups ?


also, widget sizes ?


Hi. Not sure of your question - I have a number of groups and the widths vary - some are 3, some go up to 25. They are unchanged from when it was editing OK

Widget sizes are default 48,6,0,6 for hor and vert

Very Frustrating - It is working again, but jumping through hoops to make it work.
More like hacking actually..

I set sizing to AUTO for EVERY dashboard item, deployed, which was a mess, then set each widget size back to manual with appropriate size settings, deployed, and the widgets were suddenly movable and re-sizeable again.

I had tried many things - setting one widget size to auto, deploy, back to manual, deploy, etc -
Only the Dev's will know...

I believe this to be a bug. From time to time I see the same behaviour. After rebooting the system everything usually works again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.