Cannot run install script

I try to use suggested install script:
bash <(curl -sL

The commend returned:
-sh: 8: Syntax error: "(" unexpected

This is on a Debian Linux. Any ideas?

1 - what platform?
2 - what version of Debian?
3 - What user is running the command?
4 - does the user have SUDO ability?
5 - is anything else showing up when you run the script?
6 - Does it die right away or does it do some things first?

Also, if it does appear to get started then post the contents of /var/log/nodered-install.log

[Edit] Another thought, is bash installed? It is available by default on most systems but maybe not yours.

If bash is not your current shell, try starting a bash shell and run the command from there.
It looks as the error message comes from sh, not from bash.

I don't think that should make any difference as the command explicitly invokes bash. As you say, the error suggests that it is from sh, which is why I wondered whether bash is not available. Until we hear from @mrohner we won't know.

the command explicitly invokes bash...

It is the current shell that interprets the "<" and parenthesis , not necessarily bash. Been there, as I use tcsh.

1 Like

Oh yes, you are right, the script will not run when invoked from sh so your advice to run bash first and then the script is correct.
Something new to learn every day, thanks.

with "sudo -i" I let run the command as root (although not recommendet) and it worked. Thanks for all your replies

No, definitely not recommended. Whether it worked or not depends on your definition of worked. Running node-red as root has risks.
Did you try the suggestions above?

OK, did install an Ubuntu 20.04 from scratch, with all the updates a newer bash was installed. Your script now works flawlessly under a regular user with sudo capability.
Thanks for your tips,

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.