Pi install script fail

Tried ti to use the install script on a pi 4 on it gives me
/dev/fd/63 no such file or directory
Something is amiss, perhaps with all the dev work something got moved?

Hi Gerry,

What is it you are trying to install?

/dev/fd/63 doesn't look like a normal place to install node-red.

On a pi 4, when in the node red directory, I run the node red install script and that is the error message I get,[edit]
I assume the script is looking for that directory on the server where the install files are and can't find it

Could you post the command you use to install node-red?

It may be an older one.
just saying

Put it on a line by itself too.
That way anyone looking can see it in its entirety.

This is what I have, but I DO NOT have a 4.
bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)

bash <(curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered)

When I google for script this is what comes up

Did you do the sudo apt update (and other stuff) before the script?

Yep.. sure did

Ok. Sorry. Just wanted to be sure.

Sorry, it is above my pay grade. :slight_smile:

I hope someone else can help you.

I'm sure one of the wizards will check in some time

There may be useful information in /var/log/nodered-install.log, what it was doing when it fell over.

Looked in folder and node red log file is dated 2022 so I don't think there is a log file for today

What do you see on the screen when you run the script? Can you post a screenshot?


I have no idea if it's related to the issue but you should not run the script with sudo.
And I think you should be in the home directory not .node-red.

Tried both ways

Can you successfully download the script (without running it)?

curl -sL https://raw.githubusercontent.com/node-red/linux-installers/master/deb/update-nodejs-and-nodered > nrscript

Looks like that worked

sudo npm install -g --unsafe-perm node-red

That seems to work, wrong script I guess

Hi again.

Glad you worked it out.

So what was the script that did work?
Just so I can be sure I am using the right one too.

That will install just node-red, the script you tried earlier, which is the correct one, will also install nodejs if necessary. The fact that it fails means there is something unusual about your system.

That assumes that the date is correctly set on the pi. Is the clock correct?
If the date is correct then the fact that the log exists means that the script has been run previously, which is interesting.

I suspect you have a problem with bash, but I may be wrong. What happens if you just run

What happens if you go to the directory where you downloaded the script, make it executable by running
chmod +x nrscript
then run it using