Can't connect to Zigbee2MQTT MQTT Server

Hi,

I have quite some troubles connecting to the MQTT Server from Zigbee2MQTT. I tried different methods but pretty much always get a "Connection refused" or MQTT offline.

Bildschirmfoto_2022-11-16_um_22.16.37

Hope anyone can help me spot my mistake or provide some guidance how to set things up the right way.

Many thanks in advance
Mike

Welcome to the forum @mikeg-de

I suggest not using that node. Just use the standard MQTT nodes configured with the appropriate topics. Also I suggest installing MQTTExplorer which is a great tool for checking what the topics should be.

Thanks @Colin for your advice. I tried the standard MQTT nodes before which were formerly connected to the Test node and they couldn't connect either. Here is the former setup:


Bildschirm­foto 2022-11-16 um 23.27.06

I noticed the protocol version 3.1.1 is not but 5 is existing in Zigbee2MQTT.

Will check out the MQTTExplorer

did you try the ip address instead ?

Yes, I did.

Why have you changed the broker node? Node red should still use mosquitto and zigbee2mqtt should be configured to use that broker.

Zigbee2mqtt connects zigbee devices to your mqtt broker.

1 Like

Good morning,

I tried different nodes if there was an issue with one Node Red extension. However, what you mentioned about mosquitto opened my eyes. I was so mislead with the MQTT Server option in Z2M that I totally forgot abotu mosquitto.

It works now. Many thanks @Colin!

Cheers
Mike