Can't get MCP4725 (I2C) to work

Dear all,

I am trying to hook up a MCP4725 (12-bit DAC) breakout board to the I2C bus of my Raspberry.
No matter that I do in Node-RED, I cannot get it to accept commands and output a voltage corresponding to msg.payload.

I have two of those boards, one configured for I2C address 0x60 and one for 0x61.

i2cdetect can see both of the boards (I connect one at a time) and reports back the right address.
At least: when Node-RED is not running. As soon as it runs, I2C ports 0x3-0x77 are all reported as being occupied, even if I have zero devices on the I2C bus.

Can anyone tell me what is going on here?? Any suggestions are very much appreciated.

FYI: the node I'm using for connecting to the MCP4725 is ncd-red-mcp4725, v 1.0.4.

Problem solved.
It turned out I had 2 different types of I2C nodes in the palette at the same time.
Apparently, that won't work.
After a full reinstall of Node RED, and installing only the MCP4725 library, all worked fine.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.