I2c display not working


i have a Chinese i2c display
link to display

when i run i2cdetect -y 1
i get

this gives me 3c??
what is my address then? when i enter 3c nr crashes.

What is want to do is display some text on the 128x64 display.
All tips are welcome.

i tried to make it work with node-red-contrib-lcd20x4-i2c and with node-red-contrib-pcf8574-lcd
and i update raspi-config to enable i2c

What pi are you using?
Please start up node-red and cause the crash again. Then copy the node-red log from the startup thru the crash and paste it to a reply.

In order to make code more readable and importable it is important to surround your code with three backticks
like this

You can edit and correct your post by clicking the pencil icon.

See this post for more details - How to share code or flow json

It is a pi 4 model 4
i deleted all that caused the crash allready because it was impossible to start node-red again

Did you install the nodes via the palette or in the cli?

Interesting there is another thread just opened with an i2c issue but the were using node-red-contribute-oled.

I would suggest installing the node via the cli to make sure it installs and we can go from there

Also what version of NR and node.js?

I will give it another try. Last night i gave it up at 2.45...

Just to be sure, it should be possible to connect a display to node red and show text?

Yes it is possible,

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.