LCD20x4-I2C raspbian bullseye 11

Hello All, I updated my Pi 0 W to buster and I cant get this node to work. The flow and node worked in the with the older versions or raspberian so my function block code should be fine. As a test to make sure the LCD and I2C is working properly I ran a python script and the display worked correctly.

Is anyone using LCD20x4-I2C or another node with Bullseye 11 with success? I am a "barely" intermediate user of node red and pi's. so any help would be greatly appreciated.! Thanks all

PRETTY_NAME="Raspbian GNU/Linux 11 (bullseye)"
NAME="Raspbian GNU/Linux"
VERSION="11 (bullseye)"

Hi Guys, Is anyone using LCD over I2C with latest version of raspberian and Node Red?

I see you open an issue on github.

Did you check this is not your problem -
Node not working on LCD20x4-I2C

Yes i did check it. To the best of my understanding with the way the code works. It is not defaulted to 0x3C in there. I have selected 0x27 and verified it correct by using the I2C detect command in the terminal. Additionally, this worked before i upgraded Raspberian and node red. So the wiring and node red code i made should be fine..

To be honest I am not sure what I should be doing to get proper help on something like this. Is what I did correct in opening an issue on GitHub and asking the question here? Any guidance I would really appreciate as I learn more about this world.

On another note. I rolled back node red to 2.0 and I also cant get it to work. So I dont think it is a node red issue per say.. Maybe it is on the OS side?

Code from git hub regarding the address below.

 if (n.address !== undefined){
            this.address = n.address;
            this.address = "0x27";

Is there a way I can use Node Red to Debug this a bit and give more information to the group?

As you said that it works OK from the command line then it's most likely a problem with the LCD20x4-I2C node, or dependencies. How did you upgrade, is it a fresh install, if so did you install this - sudo apt-get install python-smbus ?

It hasn’t been updated for 2 years so may not be compatible with latest OS. You are right to open an issue on GitHub as its not really a node red problem.

Unfortunately the author of the node hasn't responded to any of the other issues in that time either, so you may be out of luck.

You could provide some more info on what happens when you try to use it, do you see anything in the debug pane on the right, or in the node-red logs ?

Well with the help of a friend, I believe it is a problem that the LCD20x4-I2C node requires Python2 which i guess is not supported in Bullseye OS? I rolled it back to Buster and the latest version of Node Red and its working.

So i guess this node is dead in the water moving forward :frowning:

@smcgann99 Thank you for replying and offering your time to assist me. I am surprised more people are not using I2C LCDs in Bullseye. I suppose this will become more of an issue in the future. Hopefully someone can fork the repo for Python3 someday.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.