Can't get node-red-contrib-groov-io to install

Can not install the subject node to install in the pallette.

I have copied the error log. I have tried both the manual instructions and the install button and nothing works.

Any suggestions/help?


2020-03-06T19:56:33.731Z Install : node-red-contrib-groov-io 1.0.1

2020-01-01T13:11:56.798Z npm install --no-audit --no-update-notifier --save --save-prefix="~" --production node-red-contrib-groov-io@1.0.1
2020-01-01T13:12:01.558Z [err] npm
2020-01-01T13:12:01.559Z [err]
2020-01-01T13:12:01.559Z [err] ERR!
2020-01-01T13:12:01.559Z [err] code ENOTFOUND
2020-01-01T13:12:01.561Z [err] npm
2020-01-01T13:12:01.561Z [err] ERR! errno
2020-01-01T13:12:01.562Z [err] ENOTFOUND
2020-01-01T13:12:01.568Z [err] npm
2020-01-01T13:12:01.568Z [err] ERR!
2020-01-01T13:12:01.568Z [err] network request to failed, reason: getaddrinfo ENOTFOUND 020-01-01T13:12:01.569Z [err] npm
2020-01-01T13:12:01.569Z [err] ERR!
2020-01-01T13:12:01.569Z [err] network
2020-01-01T13:12:01.569Z [err] This is a problem related to network connectivity.
2020-01-01T13:12:01.569Z [err] npm
2020-01-01T13:12:01.569Z [err] ERR!
2020-01-01T13:12:01.570Z [err] network
2020-01-01T13:12:01.570Z [err] In most cases you are behind a proxy or have bad network settings.
2020-01-01T13:12:01.570Z [err] npm ERR!
2020-01-01T13:12:01.570Z [err] network
2020-01-01T13:12:01.571Z [err]
2020-01-01T13:12:01.571Z [err] npm ERR!

Looks like the explaination is right there in the log.

Not knowingly, however I will check some settings, I wonder if it is my static DNS server.

If you have a browser on the machine running node red then check you can get to the failing URL in the message. Otherwise, in a terminal, try to use ping to access the URL.

Fixed it, I was using the Cloudflare DNS, As soon as I changed this back to the default DNS from ISP all worked well.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.