Cant Install @bannsaenger/node-red-contrib-artnet-controller


my NodeRed Client is running on windows11.

I'm currently trying to send some DMX addresses & values via ArtNet to an DMX Ethernet Node Controller.
I tested it with a Software that is supposed to communicate with this device, and it worked great.

To send the DMX Data I wanted to look at the Palette @bannsaenger/node-red-contrib-artnet-controller.

When I try to install this palette, an error pops up.

2023-01-29T16:17:41.630Z Installieren : @bannsaenger/node-red-contrib-artnet-controller 0.1.2

2023-01-29T16:17:41.634Z npm.cmd install --no-audit --no-update-notifier --no-fund --save --save-prefix=~ --production --engine-strict @bannsaenger/node-red-contrib-artnet-controller@0.1.2
2023-01-29T16:17:42.543Z [err] npm
2023-01-29T16:17:42.544Z [err] WARN config
2023-01-29T16:17:42.544Z [err] production Use --omit=dev instead.
2023-01-29T16:17:44.315Z [err] npm ERR!
2023-01-29T16:17:44.316Z [err] code ENOENT
2023-01-29T16:17:44.316Z [err] npm ERR! syscall spawn git
2023-01-29T16:17:44.316Z [err] npm ERR! path
2023-01-29T16:17:44.316Z [err] git
2023-01-29T16:17:44.316Z [err] npm ERR!
2023-01-29T16:17:44.316Z [err] errno -4058
2023-01-29T16:17:44.317Z [err] npm ERR!
2023-01-29T16:17:44.317Z [err] enoent An unknown git error occurred
2023-01-29T16:17:44.317Z [err] npm ERR!
2023-01-29T16:17:44.317Z [err] enoent This is related to npm not being able to find a file.
2023-01-29T16:17:44.317Z [err] npm ERR! enoent
2023-01-29T16:17:44.318Z [err]
2023-01-29T16:17:44.318Z [err] npm
2023-01-29T16:17:44.318Z [err] ERR! A complete log of this run can be found in:
2023-01-29T16:17:44.318Z [err] npm ERR!
2023-01-29T16:17:44.318Z [err] C:\Users\marvi\AppData\Local\npm-cache_logs\2023-01-29T16_17_42_527Z-debug-0.log
2023-01-29T16:17:44.328Z rc=4294963238

I already searched the web & the forum for similar problems, but all similar problem solutions won’t solve my Problem.

Can anyone help?

It tries to use git, but cant seem to find it. Is it installed and can it be called ?

1 Like

Hi @Schmarvin ,
i had a dependency to my own extendet version of the dmxnet library.
This is now included in the original repository. So i changed the dependency back to the margau/dmxnet.
It should now install without the use of git.
Please try the version 0.1.3

Thank you so much!
It may be the issue that i hadn't GIT installed but now it works without it.
Great work thank you, once again :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.