Can't install node-red-node-sqlite

Hello everyone!
Due a my error, I reinstalled Armbian, Node Red etc... on Armbian Buster with Linux 4.14.174-odroidxu4

Everything worked, but ... (there is always a "but :))
I can't install "node-red-node-sqlite" from the command line or from the web:

16 Apr 16:48:30 - [info] Installing module: node-red-node-sqlite, version: 0.4.3
16 Apr 16:48:47 - [warn] Installation of module node-red-node-sqlite failed:
16 Apr 16:48:47 - [warn] ------------------------------------------
16 Apr 16:48:47 - [warn] npm WARN deprecated request@2.88.2: request has been deprecated, see
node-pre-gyp WARN Using request for node-pre-gyp https download
node-pre-gyp WARN Tried to download(403):
node-pre-gyp WARN Pre-built binaries not found for sqlite3@4.1.1 and node@12.16.2 (node-v72 ABI, glibc) (falling back to source compile with node-gyp)
Traceback (most recent call last):
File "/usr/lib/node_modules/npm/node_modules/node-gyp/gyp/", line 47, in
import gyp
File "/usr/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/", line 10, in
import gyp.input
File "/usr/lib/node_modules/npm/node_modules/node-gyp/gyp/pylib/gyp/", line 7, in
import ast
ImportError: No module named ast
gyp ERR! configure error
gyp ERR! stack Error: gyp failed with exit code: 1
gyp ERR! stack at ChildProcess.onCpExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/configure.js:351:16)
gyp ERR! stack at ChildProcess.emit (events.js:310:20)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:275:12)
gyp ERR! System Linux 4.14.174-odroidxu4
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "configure" "--fallback-to-build" "--module=/home/sysop/.node-red/node_modules/sqlite3/lib/binding/node-v72-linux-arm/node_sqlite3.node" "--module_name=node_sqlite3" "--module_path=/home/sysop/.node-red/node_modules/sqlite3/lib/binding/node-v72-linux-arm" "--napi_version=5" "--node_abi_napi=napi" "--napi_build_version=0" "--node_napi_label=node-v72"
gyp ERR! cwd /home/sysop/.node-red/node_modules/sqlite3
gyp ERR! node -v v12.16.2
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute '/usr/bin/node /usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/home/sysop/.node-red/node_modules/sqlite3/lib/binding/node-v72-linux-arm/node_sqlite3.node --module_name=node_sqlite3 --module_path=/home/sysop/.node-red/node_modules/sqlite3/lib/binding/node-v72-linux-arm --napi_version=5 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v72' (1)
node-pre-gyp ERR! stack at ChildProcess. (/home/sysop/.node-red/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack at ChildProcess.emit (events.js:310:20)
node-pre-gyp ERR! stack at maybeClose (internal/child_process.js:1021:16)
node-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5)
node-pre-gyp ERR! System Linux 4.14.174-odroidxu4
node-pre-gyp ERR! command "/usr/bin/node" "/home/sysop/.node-red/node_modules/.bin/node-pre-gyp" "install" "--fallback-to-build"
node-pre-gyp ERR! cwd /home/sysop/.node-red/node_modules/sqlite3
node-pre-gyp ERR! node -v v12.16.2
node-pre-gyp ERR! node-pre-gyp -v v0.11.0
node-pre-gyp ERR! not ok
npm WARN node-red-project@0.0.1 No repository field.
npm WARN node-red-project@0.0.1 No license field.
npm ERR! errno 1
npm ERR! sqlite3@4.1.1 install: node-pre-gyp install --fallback-to-build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the sqlite3@4.1.1 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

I tried,  just for test, with "node-red-node-mysql": no error.

An npm -v returns 6.14.4 and node -v v12.16.2

Can you help me?

Thank you.


Maybe this will help
then retry.


U saved me!
I owe u a coffee!

Thank u so much!


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.